0

I am using information from here and here.

I am running mariadb server on Debian 10. I download and copied the files to the server and execute the install.sh and I get the following error below.

"compilation terminated.
make: *** [Makefile:4: install] Error 1
ERROR: You need libmysqlclient development software installed
to be able to compile this UDF, on Debian/Ubuntu just run:
apt-get install libmysqlclient15-dev"

So I executed apt-get install libmysqlclient15-dev to install the libmysqlclient development software. But then I get the error Unable to locate package libmysqlclient15-dev.

I tried everything to install that library but I am stuck there.

Please kindly help me again.. Thanks in advance.

1 Answer 1

0

libmysqlclient15-dev is not available in recent Debian releases anymore.

Instead of mysql, mariadb is used. Try to install the package default-libmysqlclient-dev which installs the libmariadb-dev-compat package that should be at least somehow compatible with the origin mysql packages.

You might need to adapt the install script to support it.

2
  • jofel, thanks for reply. I already tried installing that default-libmysqlclient-dev package but I still get the same error upon executing install.sh Oct 19, 2022 at 6:59
  • Or if is not available in Debian distro, is libmysqlclient15-dev available in latest Ubuntu release? Oct 19, 2022 at 21:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .