I have two identical beaglebones that I'm working with. They have the same hostname and originally had the same IP, though I changed one to see if that made a difference. They're going to be deployed to 2 different networks.

My problem is I lost the ability to ssh into both of them. The password has not been changed and I can log in from my wife's computer, but on mine I get:

Permission denied, please try again.

finally followed by

Permission denied (publickey,password).

This wasn't a problem until I set up static IPs on them. What have I done/what can I do to fix it?

I'm running Ubuntu on both the beaglebones and my computer.

  • 2
    Have you tried getting onto the server via the console and looking at the logs? – yoonix Apr 11 '13 at 22:11
  • 2
    Please post the output of ssh -v $IP (possibly with any other options needed; the -v is the important part) – a CVn Apr 12 '13 at 9:05
  • Unfortunately, I was on a short timeline and both units had to be installed. I have a clone of the SD card, so I will be able to test this again soon. The only other thing to add is that as soon as I switched them back to DHCP, the problem disappeared. – Anthony DeSimone Apr 12 '13 at 23:52

Logs are the very first place to start.

Failing that, run sshd in debug mode on the server and see what it says:

/usr/sbin/sshd -Dd

Simular to what @fukwai2 said. I would recommend starting ssh on another port on the same machine.

/usr/sbin/sshd -d -p 2222 -v

When you run the client try with the -v flag to see if you can also get any more output.

Lastly just out of experience look at everything the output says even if you think its wrong because it has not changed sometimes you forget you did something.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.