When my computer tries to lock the screen, it fails, producing the following message:

The screen locker is broken and unlocking is not possible anymore. In order to unlock switch to a virtual terminal (e.g. Ctrl+Alt+F1), log in and execute the command:

loginctl unlock-session

The log out of the virtual session by pressing Ctrl+D, and switch back to the running session (Ctrl+Alt+F2).

There are numerous reports of this floating around, but this one is the only one that seems to have a solution. Unfortunately, it doesn't apply to me.

I am running Fedora 36.

3 Answers 3


Fortunately, that thread does have a critical piece of advice: figure out why it's broken. More importantly (since the preceding should be obvious), it tells how to do that:

$ /usr/lib/kscreenlocker_greet --testing

YMMV. For me, first off, the correct path is /usr/libexec/kscreenlocker_greet (use find if necessary), and the error is:

/usr/libexec/kscreenlocker_greet: symbol lookup error: /usr/libexec/kscreenlocker_greet: undefined symbol: _ZN12LayerShellQt6Window16setDesiredOutputEP7QScreen

At this point, try reinstalling the relevant packages and, more importantly, make sure they are up to date.

For me, it turns out this problem was due to a mismatched kscreenlocker and layer-shell-qt, caused because the latter being version-pegged by to an out-of-date qt5-qtwebengine-freeworld from RPM Fusion. (And it doesn't help that mirrors.rpmfusion.org has gone AWOL as of writing.) Removing that allowed me to install updates and the problem went away.

Hopefully knowing how to diagnose this will help someone else!

  • On Debian, that's /usr/lib/x86_64-linux-gnu/libexec/kscreenlocker_greet --testing but I still have this problem. Posted the output of that command at the bug report.
    – mYnDstrEAm
    Commented Oct 28, 2022 at 17:09

Yes, I can confirm on Fedora 36 removing this package and running dnf update helped:

dnf remove qt5-qtwebengine-freeworld
dnf update

You can also check if "dnf update" reports any problems with broken dependencies.

  • 2
    Welcome to the site. If the other answer worked for you, too, please don't post this as a new answer. Instead, you can upvote the answer you found helpful once you have gained sufficient reputation.
    – AdminBee
    Commented Feb 16, 2023 at 9:55

For me it was due to another problem (Maximum number of clients reachedMaximum number of clients reached). Killing some zombie process or closing firefox solved both problems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .