1

On Ubuntu 21.04, when I run

sudo apt update --allow-unauthenticated

I'm getting errors saying the repository has no release file and updating from such a repository can't be done securely and is therefore disabled by default. All my sources in /etc/apt/sources.list are like

deb [allow-insecure=yes,trusted=yes] http://us.archive.ubuntu.com/ubuntu hirsute main restricted

I've tried just [allow-insecure=yes] and just [trusted=yes] as well and get the same error. How can I update?

1 Answer 1

2

The problem isn’t authentication, it’s that Hirsute has reached the end of its life and been removed from the main mirrors. You need to use

deb [allow-insecure=yes,trusted=yes] http://old-releases.ubuntu.com/ubuntu hirsute main restricted
deb [allow-insecure=yes,trusted=yes] http://old-releases.ubuntu.com/ubuntu hirsute-security main restricted

etc. (And ideally, upgrade to Jammy.)

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .