348

I came across a sentence in vimdoc:

Note: CTRL-S does not work on all terminals and might block
                further input, use CTRL-Q to get going again.

and using CTRL-S indeed hangs my vim. I was thinking that it was vims fault, since there was no problem when I used C-s/C-x C-s in emacs nox. However, just now, when I was reading a man page and pressed Ctrl-s, it hung man as well (less was the output pager).

So, can someone tell me what's happening?

The terminal emulators I've testd are xterm and lxterminal. tty also has this problem. A Ctrl+q unhangs the terminal in all the cases.

  • 8
    This might be a stupid question but you didn't mention what you have tried in your question. You tried C-q to re-enable scrolling, right? – h3rrmiller Apr 11 '13 at 15:40
  • 3
    @h3rrmiller yeah, that's right. But I just would like to know why ctrl-s cause the process to hang. – Hongxu Chen Apr 11 '13 at 15:41
  • before there were keyboards with the scroll lock key C-s and C-q were the old days "scroll lock toggle". you can disable this functionality by adding stty ixany and stty ixoff -ixon to your .bashrc – h3rrmiller Apr 11 '13 at 15:42
  • 2
    This is a nowadays stupid historical setting in terminal emulators; see this related question for how to fix your terminal. – Ingo Karkat Apr 11 '13 at 15:45
  • 2
    @IngoKarkat I wouldn't say it's stupid... I still use it from time to time – h3rrmiller Apr 11 '13 at 15:57
399

This feature is called Software Flow Control (XON/XOFF flow control)

When one end of the data link (in this case the terminal emulator) can't receive any more data (because the buffer is full or nearing full or the user sends C-s) it will send an "XOFF" to tell the sending end of the data link to pause until the "XON" signal is received.

What is happening under the hood is the "XOFF" is telling the TTY driver in the kernel to put the process that is sending data into a sleep state (like pausing a movie) until the TTY driver is sent an "XON" to tell the kernel to resume the process as if it were never stopped in the first place.

C-s enables terminal scroll lock. Which prevents your terminal from scrolling (By sending an "XOFF" signal to pause the output of the software).

C-q disables the scroll lock. Resuming terminal scrolling (By sending an "XON" signal to resume the output of the software).

This feature is legacy (back when terminals were very slow and did not allow scrolling) and is enabled by default.

To disable this feature you need the following in either ~/.bash_profile or ~/.bashrc:

stty -ixon
| improve this answer | |
  • 11
    Actually I think it goes at last as far back as the 70's, if not the 60's. – Keith Apr 11 '13 at 18:17
  • However it seems not working on Ubuntu 16.04. – Robert Nov 23 '17 at 2:32
  • 4
    "stty -ixon" <----- this is one of the most important things I've read on the internet in the last week. thank you. – Brad P. Jan 23 '19 at 13:08
  • Actually, the history of this starts several decades earlier than 80's. See The TTY demystified. – RoboAlex Feb 4 '19 at 8:41
  • If, for whatever reason -- you globally remapped ("inactivated") Ctrl-Q (e.g. to avoid accidentally quitting Firefox), adding stty -ixon to your ~/.bashrc enables Ctrl-q in terminals. In my case, Ctrl-s was freezing Vim and I could not get back to it ... until I made that .bashrc modification. Details here: superuser.com/a/1328326/409327 – Victoria Stuart Mar 1 at 18:47
30

At the end of my .bashrc script I have added:

#so as not to be disturbed by Ctrl-S ctrl-Q in terminals:
stty -ixon

Edit: over time I have removed this line from my config, as I eventually find it handy to freeze the terminal output with Ctrl-S and resume it with Ctrl-Q. It is not useful everyday, but it's nice to have.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.