I want to upload files from my local computer to a remote server SSH through MobaXterm. I keep running into different issues that simply don't allow me to do this. I'm running Debian GNU/linux 10 (buster)

I encountered a similar problem like OP in this thread. When using the drag and drop, the upload just stays at 0%.

I've tried the suggestions changing the SSH-browser type under advanced SSH settings, to SCP(enhanced speed) and SCP (normal speed). Neither fixed it. If i change it to SFTP I get "Permission denied" when I try to drag and drop.

I followed suggestions from this thread, using the scp command. However, I'm either doing something wrong when setting the path to the file i want to upload, or something else is wrong.

1. attempt: I tried doing the scp command just using one file. I've done this using the method below, and also tried adding the full path to it, like I've done in my 2. attempt.

scp file.wav root@IPaddress:/home/folder-i-want-to-upload-to/

2. attempt I then did it by defining the path of my local host path to the folder of files i want to upload. Doing it with and without -r

scp -r /C:/Users/Name/Desktop/Folder-with-my-files-in root@IPaddress:/home/folder-i-want-to-upload-to/

scp /C:/Users/Name/Desktop/Folder-with-my-files-in root@IPaddress:/home/folder-i-want-to-upload-to/ 

Both attempts connect to my remote host, and asks for a password. Once I put that in, I just get this error:

/C/Users/Name/Desktop/Folder-with-my-files-in: No such file or directory

Same error happens for all my attempts. I can't work out what I'm doing wrong.

Ideally I just want to do the drag and drop. I've run it all through root access. I can write to all folders.

  • 2
    "I'm running Debian GNU/linux 10" – Yet some things in your question suggest the local OS is Windows. Oct 11, 2022 at 7:19

1 Answer 1


The second link you provide is about permissions, and since this is Debian and you are root, I doubt that it is due to permissions (though AppArmor exists).

Accepted answer to the first link you provided is this one, and since you did not provide actual paths you use this might solve your problem. However suggesting use of SCP rather than SFTP is fine as SFTP needs to be enabled in /etc/ssh/sshd_config file on the server.

Assuming above isn't the case, try running this within MobaXterm (without SSH'ing, make sure you have that colorful /home/mobaxterm line):

scp -r /drives/c/Users/Name/Desktop/Folder-with-my-files-in root@IPaddress:/root/scp-test/

Mind that, this will copy under root account's home directory just to be on the safe side.

AFAICT, MobaXterm uses CygWin under the roof, and above path is the way to refer to Windows disks rather than /C:. Try writing / and hitting TAB to see what else is there. I am not 100% sure this will work, comment if doesn't. I expect to have drag-n-drop working as long as command-line works.

Lastly, that -r for scp is required if you want to move a directory, or it would error out, though you cannot seem to reach that far.

  • I worked out what the issue was. I'm just an absolute idiot. Had to change permission code from 775 to 777. There's no issues now. Thank you for your in-depth answer though! Oct 11, 2022 at 11:37
  • 1
    @Noideawhatimdoing could you kindly edit your question to clarify what permission was the issue? I did not understand the problem, and surely some future guy will appreciate the explanation. Also, that 777 is generally frowned upon, try scp'ing the file as user whose home directory is used or execute chown after copying the files over.
    – cbugk
    Oct 11, 2022 at 18:36
  • 1
    Changing permissions to 777 is (almost) NEVER the right solution - it compromises the security of you target host. There are clearly a whole lot of other things going on which you've not told us about.
    – symcbean
    Jun 7 at 9:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .