I have a brand new Ideapad 5 (model 15ABA7) with a fresh install of Debian. I am struggling to get wifi to work as it seems linux isn't recognizing the wlan adapter. The only networking device that shows up in lspci is the ethernet adapter.

$ lspci | grep Network
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device b852

No wlan adapter is detected by nmcli:

$ nmcli device show
GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536
GENERAL.STATE:                          10 (unmanaged)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.GATEWAY:                            --
IP6.ADDRESS[1]:                         ::1/128
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = ::1/128, nh = ::, mt = 256

Output of lshw:

$ lshw -class network
  *-network UNCLAIMED
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: cap_list
       configuration: latency=0
       resources: ioport:2000(size=256) memory:fd600000-fd6fffff
       description: Ethernet interface
       physical id: 1
       bus info: usb@2:1
       logical name: enx606d3cbc9fcf
       serial: 60:6d:3c:bc:9f:cf
       size: 1Gbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v2.16.3 (2022/07/06) duplex=full ip= link=yes multicast=yes port=MII speed=1Gbit/s

The wireless adapter is supposedly a RTL8822BE. WiFi worked in windows so I don't think it is a hardware functionality problem.

Things I have tried:

  • installed firmware-realtek package
  • installed rtw89 driver from lwfinger
  • cmos reboot (hold power button down for 60 seconds)
  • secure boot is disabled (first thing I did before debian install)

To no avail. Anyone else get wifi working with this chipset?

1 Answer 1


I just got mine working. It's not rtw89 but rtl8852be as found here: https://github.com/HRex39/rtl8852be

(seems the chip is a realtek 8852be, though it just says "b852").

I'd already installed the dependencies as listed on https://github.com/lwfinger/rtw89 so you may or may not need those first.

  • I ended up buying and installing an intel AX200 and it worked with the iwlwifi firmware package out of the box. It's a shame that realtek devices require community drivers from non-name github pages to work.
    – Treeman
    Oct 17, 2022 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.