5

Since upgrading my debian. Bash in dolphin's terminal is not loading the config files. However, bash in Konsole is loading these.

What can I do to get Dolphin's terminal to load these?

After some testing I note that if I start dolphin with the shell closed and then open it, then all is good (it loads the configs). However, if dolphin starts with the shell open, it does not load the configs.

$-

#↳ echo $-
himBHs

In both shells

~/.bash_profile

ll ~/.bash_profile
ls: cannot access '/home/richard/.bash_profile': No such file or directory
7
  • Does dolphin have a setting to launch your shell as a login shell? Oct 7, 2022 at 18:04
  • @glennjackman I can not find any login shell setting. I have added a section to my question. Oct 7, 2022 at 19:18
  • A possible solution (but it's not so useful in my case) is: Go to Settings -> Startup -> Show on startup and you select the second option to specify a location. That works but I prefer to save the windows state from the last time. Oct 7, 2022 at 21:23
  • 1
    @EdgarMagallon can you tell us why that works. What is your reasoning. I tried it and it seems to work, but … Oct 7, 2022 at 22:06
  • @ctrl-alt-delor I'm not really sure. I've had the same problem for a long time and I found that solution in reddit or another forum, I don't remember well. It seems that's a dolphin bug. Oct 7, 2022 at 22:30

1 Answer 1

5

This solution should be useful for some people, in my case I really like the dolphin feature about Show on Startup Folders, tabs, and window state from last time. If someone like that feature too then this solution will not be useful.

First, in dolphin you have to go to Settings -> Configure dolphin:

Now you have to choose Startup option and select the second option to specify a location:

That seems to work for everyone who has the same problem. However I've seen that's a dolphin bug though I remember reading that only in some distros this bug is present.

My current dolphin version: 22.08.1 and OS: openSUSE Tumbleweed

3
  • 1
    This does not help me in Opensuse 15.4. Also it is interesting that here unix.stackexchange.com/questions/633675/… the workaround is to do the opposite. Dec 26, 2023 at 10:43
  • Wow, and indeed, after changing the start directory to /home/username the problem is fixed. Perhaps the workaround is just do do some change. Not this specific one. Dec 26, 2023 at 10:49
  • @VladimirFГероямслава thanks for pointing that out, it will be useful for some other users. I'm not sure but I remember this issue is solved in openSUSE tumbleweed (that's the distro I use and currently it seems to be working correctly now) Dec 27, 2023 at 20:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .