0

This is a lsblk output from a live USB with pop_OS used to access to my files, sda and nvme0n1 are the important disks.:

NAME        FSTYPE     SIZE MOUNTPOINT
loop0       squashfs   2.5G /rofs
sda                  232.9G
├─sda1      ntfs     223.1G
├─sda2      vfat       513M
├─sda3      ext4       8.3G
└─sda4      swap       977M [SWAP]
sdb                  931.5G
├─sdb1                  16M
├─sdb2      ntfs     442.5G
└─sdb3      ntfs       489G
sdc                    1.8T
└─sdc1      ntfs       1.8T /media/pop-os/C++
sdd                   14.5G
├─sdd1      exfat     14.4G
└─sdd2      iso9660     32M /media/pop-os/Pop_OS 22.04 amd64 Intel
nvme0n1              232.9G
├─nvme0n1p1 vfat       100M
├─nvme0n1p2             16M
└─nvme0n1p3 ntfs     232.8G

I already had windows installed and used it normally on nvme0n1, and I just installed Debian on sda, exactly, I reduced 10GB of sda which in the installation was partitioned into:

  • 513M for /boot
  • 977M for linux-swap
  • 8.3G for /

When Debian installation finished, my Windows booted like nothing happened and I got no GRUB to choose what OS run. During Debian installation GRUB was installed, but the installer did not give me the choice for where to install it.

I suspect this is the problem. My PC is booting from Windows bootloader located in nvme0n1, and not from sda2 where I think GRUB where installed.

Am I right? Is it possible to fix it or even possible to do a dualboot in this way without having to format?? Can I install and use debian on only 10GB??

I have tried to copy the Windows EFI partition to the linux EFI partition created in /dev/sda2 by accessing from a Live USB with pop OS, but I have not been successful :(

I am a complete newbie to linux but I would like to learn and use it regularly, thanks for reading.

1 Answer 1

0

Your firmware is probably booting the nvme drive. You need to set it to boot sda instead. Many systems give you a one off choice if you press f12 while the boot initiates. Check how to do this in the manual for your motherboard/laptop. It will also show you how to make the change permanent. I have done what you have on my system (copying the Windows boot information) and it works fine. However I am using systemd boot, I doubt it’s necessary with grub.

10GB is the minimum requirement for Debian so it should boot ok. The issue is that depending on what you do with it you may run out of space but it’s fine initially.

5
  • Hi thank you very much for your answer. If I am not mistaken, the Windows boot information is on the nvme0n1p1 100M vfat partition right?. Where should I copy it? Thanks for the systemd boot mention, I will try it.
    – Pnemonic
    Oct 4, 2022 at 17:32
  • Yes the Windows UEFI information is on the partition you mention. I don’t think you need to use systemd boot. Grub should work fine without copying the Windows information just so long as your bios/UEFI firmware is set to boot sda. Did the Debian installation complete without error?
    – PonJar
    Oct 4, 2022 at 20:10
  • Yes, the debian installation went fine, no errors. I have checked the UEFI options for boot order in my motherboard (MSI Mortar Max b450m btw), but it only lets me boot from NVMe... it does not give me the option to run from sda. I have multiple options, like USB hard disk or CD, but sda (samsung sdd) is not appearing as option.
    – Pnemonic
    Oct 4, 2022 at 23:02
  • I’ve had a look at the manual for your motherboard. Looks like pressing F11 at boot time will give access to the menu that gives you choices for the device to boost for the next boot. Alternatively pressing the delete key at boot time takes you to the bios setup. On the main page there is a band near the top that shows the boot device priority. You should be able to change the order so that SATA devices boot before the nvme device. Not sure exactly how it deals with multiple SATA devices but my motherboard is MSI too and I was able to set a SATA device to boot before the nvme
    – PonJar
    Oct 5, 2022 at 8:15
  • I am indeed completely blind and did not see that in the BIOS there was an option to specifically configure disk boots, separate from a normal boot option. I was able to configure it to boot from sda with grub without any problem and everything works correctly. I had a lot of problems with previous installations and on another computer and I was so saturated that I didn't notice it. Thank you very much for your attention, I really appreciate it.
    – Pnemonic
    Oct 7, 2022 at 0:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .