1

I've set up DHCP ... and so far so good. The problem is when I try to connect a device. I did a test with Linux and each time it only sets me 1 DNS (i have set two dns server in DHCP server). It also sets me other nameservers / searches that I have not set up on the openwrt DHCP server!

PS. I have disabled the DNS of dnsmasq

enter image description here

enter image description hereenter image description hereenteenter image description herer image description here enter image description here

enter image description here

How can I disable this thing?

1 Answer 1

0

Are you sure you only have one DHCPd server on the network? Extra DNS server IPs is pretty strange.

When a client makes a DHCP request it takes any answer it receives on the assumption that the LAN is secure. There is no prioritization. Which ever server answers first wins.

3
  • yes...Don't pay attention to that "192.168.2.1" which is my lan ... and in my lan I don't have the DHCP server. In the router network, however, I disabled DHCP ... so there should only be mine! So, where does that a come nameserver fe80::d635:1dff:fe5d:74ab%wlan0 and search homenet.telecomitalia.it from? Oct 3, 2022 at 22:37
  • The strange thing is that if I use isc-dhcp-server this doesn't happen! How is it possible? Is there any setting in dnsmasq? Oct 3, 2022 at 22:38
  • Log Registry System Openwrt: Tue Oct 4 01:30:31 2022 daemon.info dnsmasq[5678]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile. How do I disable DHCPV6? Oct 3, 2022 at 23:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .