I have an old Lenovo Ideapad z570 laying around and would like to bring it to live again.

After successful installation of Ubuntu I realised that it is really slow and I don't want it, so decided to try Debian instead (amd64 version used). Installation parameters were : use whole disk, no partition for /home, added swap partition, gnome desktop env.

On reboot there was only "grub>" console and after learning how to use it I was able to boot in the OS.

Commands that worked for me in grub :

grub> set root=(hd0,2)
grub> linux /vmlinuz root=/dev/sda2
grub> initrd /initrd.img
grub> boot

In the terminal emulator commands like

# update-grub
# grub-install /dev/sda

were executed on my root location without any errors. I thought it worked but after reboot nothing changed.

Partitions on hard drive:

sda1 - efi 
sda2 - root
sda3 - swap

For some stupid reason I thought that it will be a good idea to wipe whole drive with zeros to install from "fresh" and now I don't have even grub console!

enter image description here

Using grub console from USB I was able to find that my system is now on hd1,2:

enter image description here

After setting root, linux, initrd and boot I had this:

enter image description here

1 Answer 1


After numerous of attempts to fix it I finally found the solution, I which worked for me.

I used something called boot-repair. This is a Ubuntu tool to fix issues with boot. To use it I created a live USB with Ubuntu and then followed the official instruction page:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt update
sudo apt install -y boot-repair && boot-repair

Execution finished with some warnings and even errors, but after reboot system started to work! The bad thing is that I don’t really understand what was actually wrong.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .