1

I have recently started working with CentOS 7 on a VM and I'm finding a problem with enabling powertools repository. I tried different methods described in CentOS 8 resources but none of them seems to work.

Normally, this should work:

dnf install epel-release
dnf config-manager --set-enabled powertools

*I have also tried Powertools and crb

The error I get is:

Error: No matching repo to modify: powertools.

Here is my list of repositories:

$ dnf repolist
repo id                          repo name                                          status
base                             CentOS-7 - Base                                    10,072
centos-sclo-rh                   CentOS-7 - SCLo rh                                 8,112
*epel                            Extra Packages for Enterprise Linux 7 - x86_64     13,752
extras                           CentOS-7 - Extras                                  516
updates                          CentOS-7 - Updates                                 4,244

*I also have copr:copr.fedorainfracloud.org:cottsay:devtoolset-8-make-nonblocking

I also have searched in the list of available packages under epel repo but couldn't find powertools (nor Powertools or crb):

sudo yum --disablerepo="*" --enablerepo="epel" list available | grep 'powertools'

Any help would be very much appreciated.

Thanks!

1 Answer 1

2

https://wiki.centos.org/AdditionalResources/Repositories

PowerTools - Available only for CentOS8, the PowerTools repository provides most of the developer tools. Disabled by default

6
  • I didn't notice that. Thanks @ron
    – emma
    Commented Sep 28, 2022 at 14:28
  • 1
    Is there a similar repository providing development tools for Centos 7?
    – emma
    Commented Sep 28, 2022 at 15:24
  • I've only used the repo's that are listed in that wiki, the main ones being EPEL, RPMfusion_free and SCL. The *Software Collections Library" might be what you are looking for. Consider asking this at forums.centos.org
    – ron
    Commented Sep 28, 2022 at 17:51
  • I've also never used RHEL/CentOS 8, I am on 7
    – ron
    Commented Sep 28, 2022 at 17:53
  • I think devtoolset, what will give you GCC 11 for example, comes from SCL.
    – ron
    Commented Sep 28, 2022 at 17:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .