2

I am experiencing issues with rendering in Kubuntu 22.04 after an update of various packages. The issue is that in booting with the i915 driver, the plasma task bar and also other items using direct rendering are not shown correctly (things like desktop effects work correctly funnily enough). The only way to get the system to go to a usable state is a detour via the recovery mode boot. Setting i915.modeset=0 in the grub config makes the system stuck on boot.

The output of inxi -G for the normal boot sequence is:

Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: modesetting
    unloaded: fbdev,vesa gpu: i915 resolution: 2560x1600~60Hz
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.0.5

the recovery mode boot gives:

Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: N/A
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: vesa
    unloaded: fbdev,modesetting gpu: N/A resolution: 3840x2400~88Hz
  OpenGL: renderer: llvmpipe (LLVM 13.0.1 256 bits) v: 4.5 Mesa 22.0.5

Note that in a previous question (now deleted), I seemed to have issues mostly in the plasmashell and tried things mentioned in other questions to fix problems with it, but they seem unrelated.

trying to add some more information about the normal boot, in case it can be helpful. I grep'ed for i915 in the dmesg and you can find the output below.

sudo dmesg | grep -i i915
[    1.368894] i915 0000:00:02.0: enabling device (0006 -> 0007)
[    1.369521] i915 0000:00:02.0: [drm] VT-d active for gfx access
[    1.369529] fb0: switching to i915 from EFI VGA
[    1.369693] i915 0000:00:02.0: vgaarb: deactivate vga console
[    1.370285] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=mem
[    1.370914] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/tgl_dmc_ver2_12.bin (v2.12)
[    1.502406] [drm] Initialized i915 1.6.0 20201103 for 0000:00:02.0 on minor 0
[    1.512816] fbcon: i915drmfb (fb0) is primary device
[    1.561743] i915 0000:00:02.0: [drm] fb0: i915drmfb frame buffer device
[    4.381622] mei_hdcp 0000:00:16.0-b638ab7e-94e2-4ea2-a552-d1c54b627f04: bound 0000:00:02.0 (ops i915_hdcp_component_ops [i915])
[    4.457265] sof-audio-pci-intel-tgl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

some of these seem unrelated to graphics, but at any rate, nothing hints at an issue.

I am including a picture below to try and illustrate the rendering issues. It is not very clear, but on top of the empty firefox window there is a frame around the window title. This is actually the ALT+F2 launcher which does not get rendered at all. It is functional though which I can verify by e.g. typing gimp or sth like this blindly. Similar things happen for mouseover overlays from the plasmashell task bar

I tried switching sddm to lightdm but also this did not bring about any change in behavior.

Any hints on how to resolve this issue are gladly appreciated. Let me know if I can provide other information to narrow down the problem.

EDIT:

looking around some issues with the i915 drivers seem to be solvable by changing kernel boot parameters. Rather unmotivated I changed a few of them without any change, listed below

i915.enable_psr=0 # no change
i915.enable_fbc=0 # no change

EDIT 2:

further parameters I tried:

intel_iommu=igfx_off

to switch off the internal graphics engine according to e.g. this post.

I also tried installing and running the OEM kernel with no change. Note that the problem can be circumnavigated somewhat e.g. for the plasmashell by forcing software rendering. I can get a functional plasmashell environment by running

pkill plasmashell && LIBGL_ALWAYS_SOFTWARE=1 plasmashell

rendering issue

question originally posted on askubuntu but deleted there

1
  • wccftech.com/… Estimated launch as quickly as next year (2023). The i915 graphics driver was initially introduced during the 915G Northbridge chipset generation. The new Xe-based driver is fort the iGPUs on Tiger Lake and higher - it's possible that after another few generations, the old i915 driver will be retired.
    – Mexsalem
    Dec 28, 2022 at 21:17

0

You must log in to answer this question.

Browse other questions tagged .