I have a computer with debian installed. Recently I upgraded the OS (apt update, apt upgrade, apt dist-upgrade). After rebooting, grub enters rescue mode and shows the error message "Error: symbol 'grub_disk_native_sectors' not found.".

How can I fix it to boot normally into my system?

I have two drives with three partitions each one, some of them encrypted:

-- sda
------> sda1 (var, encrypted)
------> sda2 (swap)
------> sda3 (home, encrypted)
-- sdb
------> sdb1 (boot, NOT encrypted)
------> sdb2 (encrypted)
------> sdb3 (encrypted)

I've tried following the steps described here https://phoenixnap.com/kb/grub-rescue. However, on executing insmode normal I get the same error as when booting.

After downloading a current Debian iso image and booting it to a USB stick, I've tried entering rescue mode to execute other commands I found online on questions to fix grub like update-grub. However, I don't know how to make it. The partitions are all correctly identified and I'm able to decrypt them as well. Then, I'm asked to choose what device I want to use as my root file system. I can only choose /dev/mapper/sda1_cryp or the use installer itself.

What are the next steps?

The kernel images saved on /boot are 4.19.0-6, 5.10.0-16 and 5.10.0-18.

1 Answer 1


1.) Download this ISO and Rufus it to a pen drive.

2.) Boot up from the pen drive and follow the instructions.

*.) If that doesn't fix it automatically generate a detailed report and come back here to attach let us check it.

Expected behavior after boot up the disk:

enter image description here

enter image description here

  • After choosing the language, I'm shown a screen with in the center "Boot-Repair-Disk / 32 bit session" and at the bottom "F2" to "F6" with "No Texts!". There are no instructions on what to do. If I press F2 I can rechoose the language, with the other F-keys nothing happens. Wouldn't it make more sense to use debian's own recovery tool?
    – Robe
    Sep 26, 2022 at 7:00
  • @Robe I updated the answer. Boot repair is very simple tool and boot consist of only two steps that requires two enters. Can you confirm that you cannot see the Boot Repair conversation panel?
    – supi007
    Sep 26, 2022 at 7:48
  • Ah, pressing enter a second time was what was missing. The URL is pastebin.ubuntu.com/p/tRtGCzPVCH
    – Robe
    Sep 26, 2022 at 9:06
  • Your disks are structured well. It can be seen your MBR is located on sdb1 Afai can remember Boot Repair has MBR options tab under Advanced options. Choose please the Restore the MBR of: sdb (generic mbr)
    – supi007
    Sep 26, 2022 at 9:45
  • 1
    I tried it out and it worked. I was afraid that there would be problems because I mounted the encrypted partitions on "random" locations with "random" names (not the ones which are automatically assigned to them by default - I didn't know them), but it was not the case. Thanks!
    – Robe
    Sep 26, 2022 at 14:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .