0

I installed the Mistuba 2 package (https://github.com/mitsuba-renderer/mitsuba2) to be able to run btf-rendering (https://github.com/elerac/btf-rendering/).

However, to install Mitsuba it is necessary to use clang9 and some other obsolete packages. When trying to install these packages, linux gives me an error message that I couldn't solve, but I suspect that it will be necessary to downgrade the system.

Command to be executed:

sudo apt install -y clang-9 libc++-9-dev libc++abi-9-dev cmake ninja-build

And the following error is generated:

vitor-avancini@Nabucodonosor-desk:~$ sudo apt install -y clang-9 libc++-9-dev libc++abi-9-dev cmake ninja-build
Reading package lists ... ready
Building Dependency Tree ... Ready
READING STATE INFORMATION ... READY
Ninja-Build is already the latest version (1.10.1-1).
Cmake is already the latest version (3.22.1-1ubuntu1.22.04.1).
Some packages could not be installed. This may mean that
You have requested an impossible situation or, if you are using the
unstable distribution that some required packages were not
Created still or were removed from the "Incoming".
The following information can help solve the situation:

The following packages have mismatched dependencies:
  lib32gcc-s1: Break: lib32gcc-s1 (<1:10) But 1: 8.4.0-1ubuntu1~18.04 is to be installed
  libc6-dev: Break: libc7-dev (<7.5.0-6 ~) but 7.5.0-3ubuntu1 ~ 18.04 is to be installed
E: Impossible to correct problems, you kept broken packages.

System Info:

Kernel: 5.15.0-48-generic x86_64 bits: 64 compiler: gcc v: 11.2.0 Desktop: Cinnamon 5.4.12
    tk: GTK 3.24.33 wm: Mutter dm: LightDM Distro: Linux Mint 21 Vanessa base: Ubuntu 22.04 jammy

How solve this problem?

1 Answer 1

1

The clang installation instructions are obsolete; you should run the following command instead:

sudo apt install -y clang libc++-dev libc++abi-dev cmake ninja-build

To build Mitsuba 2, follow the instructions, but use

export CC=clang
export CXX=clang++

instead of the direct references to clang-9 and clang++-9.

It seems you’ve added 18.04 repositories to your configuration, if that is the case you should remove them.

3
  • I need install clang-9, not the newer. How i can remove the old repository and use an updated one?
    – V.Avancini
    Sep 27, 2022 at 15:22
  • No, you don’t need to install clang-9. The instructions are obsolete, you can use current versions of clang as long as you refer to the generic compiler drivers (see my update). I’ve done this, specifically with Mitsuba 2, and it works. Sep 27, 2022 at 15:53
  • this answer fixed my issue while I was following the instructions on Aseprite github page to build for Ubuntu.
    – Eaweb
    Jan 2, 2023 at 6:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .