I am trying to add a second (unformatted) IDE hard drive to a QNX 6.4.1 VM (hosted through vmware's vSphere). Unfortunately, there is no entry for the drive in /dev (I think this is called an enumeration... is that correct?)

I would have expected an entry named /dev/hd1 that I could then put a QNX6 filesystem on, partition, and mount. But all I see is /dev/hd0.

devb-eide is running. I tried moving it from Primary Slave to Secondary Master in the BIOS, but it didn't seem to help.

This has always worked for me on my local VMs before, but now that we are hosted in vSphere, I don't know. Can someone please point me in the right direction?

BIOS screenshot /dev screenshot

Update: So it looks like QNX calls /dev/hd0 a "Hard Disk Block Device" Link

/dev/hdn Hard disk block devices; data representing an entire drive, spanning all partitions; see devb-* in the Utilities Reference.

Is the term "Hard Disk Block Device" standard across many *nix?

Update: For what it's worth, I also do not get a /etc/fstab showing up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.