0

I am trying to deploy a web app in a VM, but if I use a NAT adapter, that VM is assigned a private IP. I want to use the bridge adapter to give the VM a real IP in my DHCP network. Both host OS and guest OS are ubuntu 20.04 LTS and when I start the VM with the bridge adapter I only get a message saying: Connection Failed Activation of network connection failed

I've searched for a solution for a while now but I can't seem to find one.

My current config of the network adapter is:

Adapter Config

How can I get my VM to have an internet connection with the bridge adapter?

1 Answer 1

2

Is your connection wireless? Look here https://help.ubuntu.com/community/KVM/Networking.

It says:

Warning: Network bridging will not work when the physical network device (e.g., eth1, ath0) used for bridging is a wireless device (e.g., ipw3945), as most wireless device drivers do not support bridging!

1
  • Yes it is, thank you so much I've tried several ways but nothing worked
    – Francisco
    Sep 19, 2022 at 8:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .