2

I have Centos 6.3 running on this pc. The built in sound card is detected normally and is a 7.1 card with all speakers listed. It includes a optical out as well as HDMI for the built in video. It looks like pulse audio is automagically misconfiguring the optical out, as it is listed as stereo digital out. The analog out is listed as analog stereo - analog surround 5.1. There are 4 or so different variations listed in the pulseaudio sound applet. If I select the test sound it has left and right front. I get audio through the digital connection but is only those 2 channels.

opening alsamixer it appears that the surround is activated and detected. It defaults to pulseaudio for both input and output. If I select the hardware card instead, it appears they are turned on properly.

I need a way to specify that digital audio is more than 2 channels, or create a specific profile for sound through the iec958 link with 8 channels.

  • It appears there may be a bug in either pulse audio and or alsa. I can with no trouble get hdmi 5.1 and analog 5.1 to work on several os's but optical 5.1 seems to be an after thought at best. I will post more in a while when i get a chance to poke at it some more. I have a working alsa/pulse config I just need to see if there is a specific version that works or not. – Kendrick Feb 10 '14 at 23:52
0

http://ubuntuforums.org/showthread.php?t=1608804 this post covers ubuntu i found that you can not use the asound.conf as it crashes pulse audio. I had used the same pulse audio settings from fedora though.

for fedora/centos you have to install the a52, ffmpeg and lacreate? libs. it took a bit of digging to figure out what libs they were in now as names have changed. I had it working in fc23 with a bit of digging on what provides what.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.