Goal: mount remote folder via sshfs on local system on boot

I have an empty USB attached to my machine: /media/steve/downloads-remote/ There is one folder inside the drive Downloads The permissions of the drive and the folder are: drwxrwxrwx

When I run this command: sshfs [email protected]:/mnt/mpathw/steve/Downloads /media/steve/downloads-remote/Downloads -o allow_other,reconnect

The drive is mounted, and the two directories are linked. I can see folders, add/remove edit on both sides and everything works as expected.

Now I am trying to achieve the same thing, but have this drive mounted on boot permanently.

I have edited fuse.conf and added: user_allow_other

Then I have edited my fstab file and added this:

[email protected]:/mnt/mpathw/steve/Downloads  /media/steve/downloads-remote/Downloads  fuse.sshfs  allow_other,identityfile=/home/steve/.ssh/id_rsa,default_permissions,idmap=user,reconnect,uid=1000,gid=1000  0  0

Now, after rebooting my system:

First it creates another mounting point, so that my media folder suddenly looks like this:


My original /Downloads folder has now been pushed onto downloads-remote1

When I try to access /media/steve/downloads-remote/ I get Permission Denied.

When I check the permissions of /media/steve/downloads-remote/ I see drwx------ 3 root root.

I then changed the permissions with: sudo chmod -R a+rwx downloads-remote, so now permissions look like this: drwxrwxrwx 3 root root

Now I can enter into /media/amir/downloads-remote/Downloads, however, there are no files there, it is not synced with the remote server.

What is missing from my setup?

  1. I don't want it to create this new directory downloads-remote1, I want it mounted just like I have it when I use sshfs directly. /media/steve/downloads-remote/Downloads

  2. Why does is it assigning the folder to root and making me change the permissions?

  3. Why does it not seem to be actually connected to the remote drive, since I can't see any of the files/folders.

  • You should be able to fix some things by adding option _netdev to the fstab entry, so systemd waits until the network is available.
    – meuh
    Sep 16, 2022 at 16:17
  • @meuh I've added _netdev, now everything is the same, except now it also mount /media/steve/downloads-remote/Downloads. Before it was only going to /media/steve/downloads-remote, but everything is still the same. 2 folders created, and neither is syncing with remote.
    – Amir
    Sep 16, 2022 at 16:39
  • man systemd.mount seems to say that many dependencies are automatically determined and create After= in the created Unit. However, you could try explicitly adding option x-systemd.requires-mounts-for=/media/steve/downloads-remote. Also, try looking in the logs, perhaps with sudo systemctl status media-steve-downloads\x2dremote-Downloads.mount or all of them sudo systemctl status '*'.mount.
    – meuh
    Sep 16, 2022 at 18:52

1 Answer 1


In the end I couldn't get it to work. There are issues with authentication, checking logs, it seems like at times it tires to connect before eth is up...sometimes it's some other error.. in any case way to much troube for what I'm trying to do.

In the end I just created a bash script that ran on startup and ran the sshfsline

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .