I've used 2 usb's, both livelinuxusb and unetbootin, and tried multiple reinstalls and formats. Whenever I try and install Archlinux x86_64 it unpacks the kernel and the says "0.000 fast tsc calibration failed" after that the computer runs but the screen turns off. What am I doing wrong?


I forgot that I asked this question until someone else submitted an answer. My fault for not updating with the actual answer but better late than never. The real problem was that the PC I was trying to install on had misconfigured BIOS options. Somehow the BIOS was trying to read the CD/DVD drive and the HDD as a single RAID array. This didn't worked and so it gave a cryptic error when trying to install Arch. I turned off RAID entirely in the BIOS and my install worked perfectly.

| improve this answer | |

You don't need to use Unetbootin or any other program to burn the image on a USB drive. You can just use the dd command in a Linux system.

Run the following command, replacing the /dev/sdx with your drive, e.g., /dev/sdb. (Do not append a partition number, so do not use something like /dev/sdb1)

dd bs=4M if=/path/to/archlinux.iso of=/dev/sdx status=progress oflag=sync

By doing this, the system will boot like a burned CD, because dd burned the ISO file to a USB drive.

If you are using Windows systems you can use Rufus, for example. It is easier than Unetbootin and you can burn images on a GPT partition and UEFI mode.

Read more on Archlinux pre installation guide. There is a topic on BIOS and UEFI bootable USB.

| improve this answer | |
  • The question wasn't about how to burn an image it was about a specific error message. – torchhound May 21 '18 at 0:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.