1

After downloading the Intellij IDEA programming software, the Installation document suggests that I add it to the PATH Environment, yet I am unable to do so using the "export" command as many of the forums suggest.

I run the command as so:

sudo export PATH=/home/myusername/Programming/idea-IC-222.4167.29/bin:$PATH

Yet am met with this error message:

sudo: export: command not found

I have tried finding solutions to this and am struggling. I've also tried finding guides on how to install the export function onto my system but have had no luck.

I'm using ParrotOS Security Edition 5.0 Electro Ara.

Any suggestions/help would be much appreciated, thanks.

1 Answer 1

1

Using sudo doesn't help you here. The export statement changes the environment of the currently running process (only). The same statement without the sudo in front will probably work in your current shell (where you typed the export statement), but not in any other window or even user session.

export PATH=/home/myusername/Programming/idea-IC-222.4167.29/bin:$PATH
command -v idea.sh # this should print /home/myusername/Programming/idea-IC-222.4167.29/bin/idea.sh
idea.sh            # this should start IntelliJ

In order to permanently change the PATH variable for your user, theere are many possibilities. I explored a little once in this answer

1
  • This worked, thank you! As a novice with Linux I got so used to running every command with sudo I never considered this. Thanks for solving my problem and helping me deepen my understanding at the same time 😁
    – CyberJay
    Sep 15, 2022 at 21:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .