I use two OpenBSD machines (notebooks) that have configured mutt clients. One of them has OpenBSD 7.0 on it with mutt version 2.1.3, while the other runs OpenBSD 7.1 with mutt 2.2.3 . Both of them use exactly the same mutt configuration file.

Reading emails makes no trouble on neither of the machines. A problem rises when I try to send an email on "newer" (in terms of OBSD version) machine.

I can't send any email from that machine. Trying to send an email to myself results in SMTP session failed: 553 5.7.1 You are sending spam (check https://lookup.abusix.com/search?q=X.Y.Z.W where X.Y.Z.W is my ip address.

I am using wired connection to access the network. On older machine (with 7.0 on it) there is no such problem. I can send emails to myself and others.

What can cause such a difference?

1 Answer 1


So apparently the answer is exactly the same as posted to a similar question: https://unix.stackexchange.com/a/383025/452918

Not much of an explanation why on the other machine everything works fine but solves my problem nonetheless.

The solution is to use full email address (followed by the server name) while setting the smtp_url variable in .muttrc file.

If for example you have an email address "[email protected]" and your SMTP server is "darkspade.com" then the correct value (at least in my case) of smtp_url is [email protected]@darkspade.com (yes, the double @ is not a typo)


It seems that version 2.1.5 of Mutt might have changed how SMTP authentication works internally. According to (see commit 91474fdf): https://gitlab.com/muttmua/mutt/-/raw/mutt-2-1-5-rel/ChangeLog One of the commits included in that release mentions that username is no longer added automatically.

It just a thought but seems what could have cause the difference in behavior between versions 2.1.3 and 2.2.3 .

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .