8

Right after session starts, GNOME wants you to select from one of the available workspaces, even if there's just one.

I'd much rather have this option disabled altogether, or perhaps have the 1st one to be 'selected' automatically. I mean, even if it's just a click, it's just useless for me and annoying.

Can this be done? What is this 'feature' called? I couldn't find any option related in either tweaks or settings (dconf perhaps?).

4
  • I think what you ask for is the default behavior. Do you have an extension installed that changes that?
    – user10489
    Sep 13, 2022 at 11:25
  • @user10489: nope I don't. Is there any? I wonder whether there's any setting or so to change that w/out extensions
    – edmz
    Sep 13, 2022 at 11:35
  • Which version of GNOME are you using? Sep 13, 2022 at 15:46
  • @BrianReading: latest one, 42.4 (arch linux)
    – edmz
    Sep 13, 2022 at 21:43

3 Answers 3

6

If you're using GNOME 42 with default behavior, then what you're seeing is the "Activities Overview". It's not actually asking you to pick a workspace, but instead asking you to open whichever app you intend to start with.

GNOME developers have been asked about this, and there is a lengthy discussion that occurred on the GNOME Discourse in 2021. In the end, they have noted that they have no intention to change the default behavior or add ability to toggle it.

Regardless. If you'd like to disable that, and have it go to your desktop instead, try the "No overview at start-up" shell extension.

3
  • Thanks Brian. I've installed the extension and it's gone. Also ty for the link, I went through it a bit and indeed they do seem to genuinely appreciate the feature: I mean, devs do. Users much less. It's just nonsense if e.g. you don't have sessions stored: I have to "overview" activities every time I boot up, but there's ofc none, yet I have to choose a workspace.
    – edmz
    Sep 14, 2022 at 10:51
  • Another possible option would be to just add an app in your login startup that opens a window.
    – user10489
    Sep 19, 2022 at 1:52
  • @user10489 what do you mean by that? I have commands that open windows on 3 separate displays yet I still have to deal with this cumbersome overview.
    – Cheetaiean
    May 11, 2023 at 22:33
2

if you're using the dash to panel extension, you can configure it at

extensions -> dash to panel -> settings -> behavior -> overview -> disable show overview on start up

1
  • 1
    Best solution for ones, using dash-to-panel! Works like charm!
    – Apogentus
    Jan 18 at 9:52
1

I've developed a different solution that isn't based on shell extensions (and thus should be more resilient to newer gnome versions and future incompatibilities).

This solution can be implemented system-wide or affecting just a user, depending on where the files are put. OBS: Please notice that the first file must be made executable with chmod 755 /usr/libexec/no-overview-at-startup or chmod 755 ${HOME}/bin/no-overview-at-startup depending on if you will use the system-wide or user-specific approach.

First the files to be used if you chose the system-wide approach:

File 1: /usr/libexec/no-overview-at-startup.

#!/usr/bin/sh

# Monitoring time in tenths of seconds
MTIME=50
for ((i=0; i<${MTIME}; i++)); do
  read -r DUMMY DUMMY IS_OVERVIEW <<< "$(dbus-send --print-reply=literal --session --dest=org.gnome.Shell --type=method_call /org/gnome/Shell org.freedesktop.DBus.Properties.Get string:org.gnome.Shell string:OverviewActive)"
  if [[ "${IS_OVERVIEW}" = "true" ]] ; then
    /usr/bin/dbus-send --session --dest=org.gnome.Shell --type=method_call /org/gnome/Shell org.freedesktop.DBus.Properties.Set string:org.gnome.Shell string:OverviewActive variant:boolean:false
    exit
  fi
  sleep 0.1
done

File 2: /etc/xdg/autostart/no-overview-at-startup.desktop.

[Desktop Entry]
Type=Application
Exec=/usr/libexec/no-overview-at-startup
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[en_US]=No Overview at Start-up
Name=No Overview at Start-up
Comment[en_US]=Disable overview mode right after login
Comment=Disable overview mode right after login

Alternatively, in order for this to affect only a user, the files should be placed in different directories and a change in File 2 is required:

File 1 location: ${HOME}/bin/no-overview-at-startup.

File 2 location: ${HOME}/.config/autostart/no-overview-at-startup.desktop.

Important: File 2 must have the line beginning with EXEC=... changed to EXEC=${HOME}/bin/no-overview-at-startup.

Finally, if you are using Fedora and have experience on building RPMS, here it is a .spec file for this purpose (valid only for the system-wide approach):

File 3: gnome-shell-no-overview.spec

Name:       gnome-shell-no-overview
Summary:    Disable the overview mode on startup
Version:    0.1
Release:    1%{?dist}
License:    freeware
Source0:    %{name}-%{version}.tar.gz

BuildArch:  noarch
Requires:   gnome-shell

%description
gnome-shell-no-overview is a bundle of startup app and script designed to disable the initial overview mode imposed by gnome in recent 4x releases.  This is accomplished by a script that monitors if the overview mode is activated in the first 5 seconds after the startup and sends a dbus message changing it back to the desktop mode

%prep
%setup -q

%build
true

%files
%doc
/usr/libexec/no-overview-at-startup
/etc/xdg/autostart/no-overview-at-startup.desktop

%install
install -D -m 755 %{_builddir}/%{name}-%{version}/no-overview-at-startup %{buildroot}/usr/libexec/no-overview-at-startup
install -D -m 644 %{_builddir}/%{name}-%{version}/no-overview-at-startup.desktop %{buildroot}/etc/xdg/autostart/no-overview-at-startup.desktop

If you need help on building the Fedora package, drop me a line in the comments and I can give you more details.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .