1

I have a TFTP server running on Windows-10 machine.
I am using MobaXterm it has TFTP server.

enter image description here

I tested client server running on same windows 10, machine, able to communicate.

TFTP -i 192.168.1.7 get test.txt
Transfer successful: 11 bytes in 1 second(s), 11 bytes/s

My TFTP server directory on windows is :--

C:\S32G2_images

enter image description here

My target board, using uboot i am trying to TFTPboot buts connection is not establishing with the TFTP server running on the windows 10 machine.

Please suggest how to resolve this ?

Target Board Uboot setting :--

enter image description here

PC, running windows-10 :-- enter image description here

Ping to TFTP server working from Uboot :--

enter image description here

trying to connect to TFTP server from Linux U-boot failing :--

enter image description here

Windows Firewall setting :-- image.png

image.png

image.png

image.png

image.png

1 Answer 1

0

Instead of trying from uboot.

I also tried to run the TFTP client from Linux booted onto my board.

PFE-2 setting on LINUX booted on S32G2 ;-- enter image description here

I added Windows-10 machine to my routing table :-- enter image description here

I am able to ping from Linux running on my board to windows-10 machine :-- enter image description here

I am able to ping from windows-10 machine to Linux running on my board :-- enter image description here

TFTP client on my board is part of busybox package.

But still same issue , not able to connect to tftp server on Windows-10 machine :--

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .