0

I recently acquired a new laptop on which i initially installed a dual-boot with Windows 11 and Fedora. Windows 11 is working perfectly, no input/mouse problems and every software is running fine.

But on Fedora, there was certain moments (random moments) where the screen was freezed (and also the input?) and I needed to force-shutdown the computer to use it again. It was a pretty frustrating bug. I finally went to delete all the data present on the Fedora disk partitions and installed an Ubuntu Desktop 20.04 from a bootable USB.

Everything is working fine, except I still have mouse freezes : the mouse (using touchpad) isn't responding for few seconds-minutes (30sec-2min) and responds again at random intervals. But this time, the screen isn't freezing so I can access the terminal using CTRL+ALT+T

I have a Synaptic Touchpad, here is the output of the xinput list command :

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ MSNB0001:00 06CB:CDAA Mouse               id=12   [slave  pointer  (2)]
⎜   ↳ MSNB0001:00 06CB:CDAA Touchpad            id=13   [slave  pointer  (2)]
⎜   ↳ PS/2 Synaptics TouchPad                   id=17   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ HD Camera: HD Camera                      id=10   [slave  keyboard (3)]
    ↳ HD Camera: IR Camera                      id=11   [slave  keyboard (3)]
    ↳ Intel HID events                          id=14   [slave  keyboard (3)]
    ↳ Intel HID 5 button array                  id=15   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=16   [slave  keyboard (3)]
    ↳ MSI WMI hotkeys                           id=18   [slave  keyboard (3)]

I come here to search for new solutions, I tried a lot of the proposed solutions on another posts or websites. None did work for me. Here are some of my tests which did not correct my problem :

  • Tried xinput --disable <ID> and xinput --enable on every mouses, touchpads detected. It worked one time but not the others. It seems that the touchpad is detected both as a touchpad and a mouse. Disabling the Synaptics TouchPad does not have any effect...
  • Installed/Reinstalled Synaptic driver xserver-xorg-input-synaptics => No effect
  • Installed libinput to replace Synaptic driver => No effect
  • Tried sudo modprobe -r psmouse and sudo modprobe psmouse => No effect

Also, I don't know if there can be a link, but when my mouse is freezed and I open an application (using keyboard and search bar + enter), the mouse unfreezes automatically.

My goal is to fix this problem permanently, not opening a terminal whenever the mouse freeze to unfreeze it.

IMPORTANT NOTE: The mouse works perfectly when used with an external device (for example a usb-plugged mouse). And when we use the touch-pad when the external mouse is plugged, it can also freeze. But when the touch-pad is freezed, the external mouse can still be used normally.

Is it a software problem (misconfiguration) or a hardware problem (maybe touchpad bug? but i dont think so because it works well on Windows)

I am open to provide logs/debugs, feel free to ask! Thanks you in advance ;)

1 Answer 1

1

The same problem occurred with me but the only difference is u've done dual boot while I use Linux by making VMs. I fixed that issue by changing my virtual pointing device from PS/2 mouse to USB tablet. U can change ur real pointing device from touchpad to any external USB mouse. The problem is in compatibility between ur touchpad drivers and fedora host OS

3
  • Thanks for your answer. But is it possible to solve the problem without absolutely needing an external USB mouse? Like replacing the driver?
    – dandan2611
    Sep 6, 2022 at 16:52
  • Try to contact ur mouse's vendor. I think they'll downgrade ur mouse by providing an immediate previous version of the driver. Hope it'll work
    – Aryan
    Sep 15, 2022 at 6:39
  • Ok, I'll do that! Thanks!
    – dandan2611
    Sep 20, 2022 at 11:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .