1

After upgrading ubuntu to 22.04 I wasn't able to login because my password has any accented vowel, as for example "ú". This happens ONLY the FIRST login.

In my case the new ubuntu 22.04 does NOT accept accented vowels in the user password when entered directly from keyboard, but this behaviour is ONLY at the FIRST login.

The workaround for me was to enter that character by the on-screen keyboard and the others from normal keyboard.

Once the password has been accepted and I get access, then the system does accept my password directly from keyboard as normal and at any other time. I tested it: I tried to enter it directly from keyboard in a terminal and it worked, and I tried to suspend system and then enter password from keyboard directly and then it worked.

So, the problem entering my password is only at the begin login, it's only then when I am in the need to enter that character of my password from an on-screen keyboard.

Anyway, I think this is NOT the properly working way that ubuntu is supposed to, as in every older versions a password with an accented vowel worked ok typed directly from the normal keyboard.

So please, notify to the appropriated person to fix this.

Thanks in advance.

2

3 Answers 3

2

I must disclose that I haven't long since daily driven GNOME3.

But it appears to me that you are forced to use a different default keyboard layout upon system boot, say US-utf8.

Below topic showcases setting a default layout for gdm3, should solve your problem if it indeed is what I suspect.

https://askubuntu.com/questions/1423550/gdm3-display-manager-always-starts-with-qwerty-even-though-i-only-have-dvorak-in

P.S. This reminds me of early 2010's, when Windows FLP (Fundementals for Legacy PCs) would enforce use of US layout throughout the installation and the initial login screen. That made me re-install the OS multiple times as I had Turkish characters in my password and could not get in. Solution was, and I stick by it ever since, use of common letters and symbols activated by same key presses as the US layout; keep non-ASCII and misplaced keys out.

6
  • 2
    +1 for "Solution was, and I stick by it ever since, use of common letters and symbols activated by same key presses as the US layout; keep non-ASCII and misplaced keys out." My comment: use ASCII 32-126 (space - tilde); or even tighter: maybe skip space and some other characters with a special meaning in Linux, Windows and/or MacOS.
    – sudodus
    Sep 5, 2022 at 17:05
  • 1
    It can be better to have a longer password with standard ASCII letters than a shorter password with some special characters. See this link, and scroll down to the XKCD method.
    – sudodus
    Sep 5, 2022 at 17:42
  • @roaima while at it better to use a password manager for web, so long as one tests actually logging into the system at least once. The topic revolves around manual offline logins AFAICT. So good old ASCII crossed with your favorite Latin alphabet should work just OK.
    – cbugk
    Sep 5, 2022 at 17:53
  • @roaima, What do you mean by online password? And do you know why it had to be blocked? Too many failures to type correctly or too many forgotten passwords? (I use a long master password to a file, where I have a lot of passwords to paste into various web sites, and it works well for me.)
    – sudodus
    Sep 5, 2022 at 17:54
  • HorseBattery... was apparently being used for real as a password to cloud services Sep 5, 2022 at 17:56
2

The fact is that now it works.

I suspect that it has been due to sudo apt update and sudo apt upgrade commands that I run from terminal when I was trying to solve other problem.

I have not changed any other thing.

As a curiosity, I am spanish using spanish keyboard and my /etc/default/keyboard file is as follow:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="es"
XKBVARIANT=""
XKBOPTIONS=""
BACKSPACE="guess"

But as I have said above I didn't change anything manually. The fix can become from commands in terminal said before, I suspect.

2
  • Thanks for sharing your solution :-)
    – sudodus
    Sep 13, 2022 at 8:51
  • @Norber please accept your own answer for those who will come by the question.
    – cbugk
    Sep 12, 2023 at 12:56
0

When you look at Settings > Region & Language you see this:

enter image description here

This shows how you can have different Language and Formats for the Login screen to those used generally on that user's account.

This may have a bearing on your observations.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .