1

I bought a new laptop Xiaomi Notebook Pro 14 2022 (Intel i7 12gen) (do I need a full specification?) and unfortunately I can't activate wi-fi. I've tried installing the latest Ubuntu and PopOS available images, but Wi-Fi doesn't seem to work on both out of the box (I chose pop OS). Right now, the only possible way to access the Internet on a laptop is with a modem from my smartphone.

Listed below are some specifications:

Network Controller Name (from hardware util): Realtek Semiconductor Co., Ltd. Device b852

uname -r is 5.19.0-76051900-generic

lshw -C network results:

  *-network UNCLAIMED       
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:2c:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:3000(size=256) memory:5e200000-5e2fffff
  *-network
       description: Ethernet interface
       physical id: 14
       bus info: usb@3:1
       logical name: enx0edb87e86af7
       serial: 0e:db:87:e8:6a:f7
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=rndis_host driverversion=5.19.0-76051900-generic duplex=half firmware=RNDIS device link=yes multicast=yes port=twisted pair

lspci -nnk | grep 0280 -A2 results:

2c:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:b852]
    Subsystem: Device [1d3e:c826]

rfkill list results:

1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

I found different solutions, but here is what I tried:

  1. I tried installing the driver from the following github repo: https://github.com/HRex39/rtl8852be

EFI Secure Boot disabled

But this is what i get in return:

console return

...
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:249: /home/artkharlamov/rtl8852be/os_dep/linux/ioctl_cfg80211.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [Makefile:1849: /home/ak/rtl8852be] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.19.0-76051900-generic'
make: *** [Makefile:637: modules] Error 2
  1. I also found solutions to a similar problem in similar threads by installing the drivers from the following github repository: https://github.com/lwfinger/rtw89 But that didn't help either.

Tell me what I'm doing wrong and how to make my wi-fi work!

1 Answer 1

1

The firmware of these series of network cards are not supported in some older versions of Linux kernel (like 5.10-5.12) but they're [said to be] supported in newer versions though they neither work by default nor work using the PPA firmware.

I had the same issue with RTL8822CE and (1) downgrading the kernel to 5.10 and (2) installing the firmware module from a PPA in GitHub solved the issue.

my suggestion is to downgrade your kernel and install from https://github.com/HRex39/rtl8852be again.

to downgrade the kernel open a terminal and write:

sudo apt install linux-image-5.10.0-13-amd64 

this is for 5.10.0-13 version which worked for me, I hope this work for you as well!

1
  • 1
    Hello, thanks for your answer and responsiveness! Your solution is definitely working, but unfortunately I can't use it because the processor on my laptop works much better only on the latest cores (Intel 12Gen). I tried installing the driver from the following repository github.com/lwfinger/rtw8852be and.. it worked! But to my regret, with some nuances. I understand the installed driver more and more, but periodically the connection is lost for a moment (the ping grows many times, but the packets are not lost). As soon as I collect more information, I will share it. Sep 9, 2022 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.