0

I am trying to run yum update on my Amazon-Linux-2 Workspace. It crashes with the following output

❯ sudo yum update
Loaded plugins: amzn_workspaces_filter_updates, halt_os_update_check, priorities, update-motd
357 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package snap-confine.x86_64 0:2.36.3-0.amzn2 will be updated
---> Package snap-confine.x86_64 0:2.55.3-1.el7 will be an update
---> Package snapd.x86_64 0:2.36.3-0.amzn2 will be updated
---> Package snapd.x86_64 0:2.55.3-1.el7 will be an update
--> Processing Dependency: snapd-selinux = 2.55.3-1.el7 for package: snapd-2.55.3-1.el7.x86_64
--> Processing Dependency: squashfuse for package: snapd-2.55.3-1.el7.x86_64
--> Running transaction check
---> Package snapd-selinux.noarch 0:2.55.3-1.el7 will be installed
--> Processing Dependency: selinux-policy >= 3.13.1-268.el7_9.2 for package: snapd-selinux-2.55.3-1.el7.noarch
--> Processing Dependency: selinux-policy-base >= 3.13.1-268.el7_9.2 for package: snapd-selinux-2.55.3-1.el7.noarch
--> Processing Dependency: policycoreutils-python for package: snapd-selinux-2.55.3-1.el7.noarch
---> Package squashfuse.x86_64 0:0.1.102-1.el7 will be installed
--> Processing Dependency: squashfuse-libs(x86-64) = 0.1.102-1.el7 for package: squashfuse-0.1.102-1.el7.x86_64
--> Processing Dependency: libfuseprivate.so.0()(64bit) for package: squashfuse-0.1.102-1.el7.x86_64
--> Processing Dependency: libsquashfuse.so.0()(64bit) for package: squashfuse-0.1.102-1.el7.x86_64
--> Processing Dependency: libzstd.so.1()(64bit) for package: squashfuse-0.1.102-1.el7.x86_64
--> Running transaction check
---> Package libzstd.x86_64 0:1.5.2-1.amzn2 will be installed
---> Package policycoreutils-python.x86_64 0:2.5-22.amzn2 will be installed
--> Processing Dependency: setools-libs >= 3.3.8-2 for package: policycoreutils-python-2.5-22.amzn2.x86_64
--> Processing Dependency: libsemanage-python >= 2.5-9 for package: policycoreutils-python-2.5-22.amzn2.x86_64
--> Processing Dependency: audit-libs-python >= 2.1.3-4 for package: policycoreutils-python-2.5-22.amzn2.x86_64
--> Processing Dependency: python-IPy for package: policycoreutils-python-2.5-22.amzn2.x86_64
--> Processing Dependency: libselinux-python for package: policycoreutils-python-2.5-22.amzn2.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: policycoreutils-python-2.5-22.amzn2.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: policycoreutils-python-2.5-22.amzn2.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: policycoreutils-python-2.5-22.amzn2.x86_64
--> Processing Dependency: checkpolicy for package: policycoreutils-python-2.5-22.amzn2.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: policycoreutils-python-2.5-22.amzn2.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: policycoreutils-python-2.5-22.amzn2.x86_64
---> Package snapd-selinux.noarch 0:2.55.3-1.el7 will be installed
--> Processing Dependency: selinux-policy >= 3.13.1-268.el7_9.2 for package: snapd-selinux-2.55.3-1.el7.noarch
--> Processing Dependency: selinux-policy-base >= 3.13.1-268.el7_9.2 for package: snapd-selinux-2.55.3-1.el7.noarch
---> Package squashfuse-libs.x86_64 0:0.1.102-1.el7 will be installed
--> Running transaction check
---> Package audit-libs-python.x86_64 0:2.8.1-3.amzn2.1 will be installed
---> Package checkpolicy.x86_64 0:2.5-6.amzn2 will be installed
---> Package libselinux-python.x86_64 0:2.5-12.amzn2.0.2 will be installed
---> Package libsemanage-python.x86_64 0:2.5-11.amzn2 will be installed
---> Package python-IPy.noarch 0:0.75-6.amzn2.0.1 will be installed
---> Package setools-libs.x86_64 0:3.3.8-2.amzn2.0.2 will be installed
---> Package snapd-selinux.noarch 0:2.55.3-1.el7 will be installed
--> Processing Dependency: selinux-policy >= 3.13.1-268.el7_9.2 for package: snapd-selinux-2.55.3-1.el7.noarch
--> Processing Dependency: selinux-policy-base >= 3.13.1-268.el7_9.2 for package: snapd-selinux-2.55.3-1.el7.noarch
--> Finished Dependency Resolution
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I have tried yum clean all and

rm -f /var/lib/rpm/__db*
rpm –rebuilddb
yum clean all
yum update

I still get the same error. What would be the best way to fix this? Or how can I figure out what is causing it?

1 Answer 1

1

So I ran yum update --skip-broken followed by a regular yum update and through that, I was able to narrow the offending package to snap.

Doing yum uninstall snapd fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.