0

I have to confess that I missed upgrading Debian 9 to 10 on a virtual development machine. Now Debian 9 is EOL.

All I get are 404 or 403 errors when I try to fetch the necessary upgrade packages because support for Debian 9 ended on June 2022.

Err:10 https://packages.sury.org/php stretch Release 403 Forbidden

or

Err:7 https://packages.sury.org/php stretch Release 403 Forbidden

So far, I did the well-known routines for upgrading:

  1. replace every instance of "stretch" with "buster" inside /etc/apt/sources.list
  2. sudo apt update # that's where the trouble started
  3. sudo apt upgrade
  4. sudo apt full-upgrade

What can I do now to upgrade to 10 (or even 11 if necessary)? Do I have to get the packages or upgrade information from a third party? Is there any possible solution at all?

Here is the output of sudo apt update

juergen@masch1:~$ sudo apt update  
Hit:1 http://dl.google.com/linux/chrome/deb stable InRelease  
Hit:2 http://dl.hhvm.com/debian jessie InRelease  
Get:3 http://ftp.de.debian.org/debian buster InRelease [122 kB]  
Get:4 http://security.debian.org/debian-security buster/updates InRelease [34.8 kB]  
Hit:5 https://deb.nodesource.com/node_12.x stretch InRelease  
Get:6 http://ftp.de.debian.org/debian buster-updates InRelease [56.6 kB]  
Ign:7 https://packages.sury.org/php stretch InRelease  
Err:8 https://packages.sury.org/php stretch Release  
  403  Forbidden  
Get:9 http://security.debian.org/debian-security buster/updates/main Sources [255 kB]  
Get:10 http://security.debian.org/debian-security buster/updates/main 
amd64 Packages [347 kB]  
Get:11 http://security.debian.org/debian-security buster/updates/main  Translation-en [188 kB]  
Get:12 http://ftp.de.debian.org/debian buster/main Sources [7843 kB]  
Get:13 http://ftp.de.debian.org/debian buster/main amd64 Packages [7911 kB]  
Ign:14 http://download.webmin.com/download/repository buster InRelease  
Err:15 http://download.webmin.com/download/repository buster Release
  404  Not Found [IP: 104.207.151.13 80]  
Get:16 http://ftp.de.debian.org/debian buster/main Translation-en [5969 kB]  
Get:17 http://ftp.de.debian.org/debian buster/main Translation-de [1654 kB]  
Get:18 http://ftp.de.debian.org/debian buster/main Translation-de_DE [830 B]  
Get:19 http://ftp.de.debian.org/debian buster-updates/main Sources [4616 B]  
Get:20 http://ftp.de.debian.org/debian buster-updates/main amd64 Packages [8788 B]  
Get:21 http://ftp.de.debian.org/debian buster-updates/main Translation-en [6915 B]  
Reading package lists... Done  
E: The repository 'https://packages.sury.org/php stretch Release' does no longer have a Release file.  
N: Updating from such a repository can't be done securely, and is therefore disabled by default.  
N: See apt-secure(8) manpage for repository creation and user configuration details.  
E: The repository 'http://download.webmin.com/download/repository buster Release' does not have a Release file.  
N: Updating from such a repository can't be done securely, and is therefore disabled by default.  
N: See apt-secure(8) manpage for repository creation and user configuration details.  
0

1 Answer 1

4

The errors shown by apt update only concern third-party repositories. You should at least:

  • check whether they provide support for Debian 10
  • update the repository descriptions in /etc/apt/sources.list.d to reference buster rather than stretch

As it is, you have the updated repository indexes for Debian 10, so you should be able to upgrade (at least, see what apt upgrade determines — it will tell you what it wants to do and give you the opportunity to stop before it actually does it). You may however run into issues with third-party packages, and in some cases you’ll have to remove the affected third-party packages in order to successfully upgrade to Debian 10.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .