when I use lsof as regular user, I get following warnings:

lsof: WARNING: can't stat() tmpfs file system /home/testuser/.cache

testuser is another user on my systems, and my own user has no access to the tmpfs filesystem mounted at /home/testuser/.cache.

I suspect, lsof found in /etc/fstab (or in /proc/mounts) that this tmpfs exists and tries to search it and fails on not having permissions to other user's home:

$ grep /home/testuser/.cache /proc/mounts
tmpfs /home/testuser/.cache tmpfs rw,nosuid,nodev,noexec,noatime,size=4194304k,mode=700,uid=1001,gid=1001 0 0

Anyways, how can I supress these warnings, or tell lsof not to search paths of other users, or something that would get rid of this warning?

1 Answer 1


You can disable warnings with -w:

lsof -w

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .