I have been using a preseeded USB disk for a few years now, but am hitting a wall.

One of my machines needs the RTW89 module and firmware to access the internet. I have succeeded in building the driver and firmware for both (deb 11.4 installer kernel) and (deb 11.4 target kernel), and am halfway there using this approach:

  • with an early_command I can copy all files to the installer environment and
  • with a late_command I can copy all files to the target environment.

PROBLEM: the installer picks up the wlp3s0 interface, but does not scan for SSIDs, nor does it ask me to connect to a WiFi network. It tries the link on the wired and wireless interface, and runs a dhcp attempt to then fail (as expected).

If I drop to a TTY, I can connect using wpa_supplicant and udhcpc, but still the installer does not pick up the active network connection when it continues...


  1. After copying over the modules and firmware, i run 'depmod -a', but I cannot run 'modprobe XXX' in the early_command as it fails to find dependencies. I don't think this is causing the issue (d-i picks up the presence of the wlp3s0 iface after all), but still want to mention it... Should I run additional commands to make d-i aware of this preseed intervention?
  2. I am using two d-i/include commands: one for this rtw89 module and one to specify partitioning for both NVME and SATA setups (see below) - could this be causing the d-i confusion?
### INCLUDE SUB RTW89 (RTW8852 network)
d-i preseed/include_command string if [[ "`grep 8852 -c /proc/bus/pci/devices`" -gt 0 ]]; then echo preseed-sub-rtw8852.cfg; fi

d-i preseed/include_command string if [[ "`grep nvme -c /proc/modules`" -eq 0 ]]; then echo preseed-sub-sata.cfg; else echo preseed-sub-nvme.cfg; fi
  • I'm going to investigate some more, but it seems like having more than 1 early_command or more than 1 late_command is not supported - that may cause unexpected errors (I guess). To overcome this lack of flexibility, I have now set up a provisioning server that generates preseed.cfg files and serves them over http.
    – zenlord
    Aug 31, 2022 at 6:52


You must log in to answer this question.

Browse other questions tagged .