1

I'd like to use the keybinding Ctrl+Alt+b in Emacs, but it's captured by the OS (Lubuntu 22.04 LTS).

I know that Ctrl+Alt+<left> can be disabled with:

gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-left "['disabled']"

But I couldn't find what values to use in gsettings to disable Ctrl+Alt+b. I tried to use gsettings get org.gnome.desktop.wm.keybindings switch-to-workspace-left followed by a TAB key, and got the following options. But none mentioned browser.

activate-window-menu          move-to-monitor-left          move-to-workspace-right       switch-to-workspace-4
always-on-top                 move-to-monitor-right         move-to-workspace-up          switch-to-workspace-5
begin-move                    move-to-monitor-up            panel-main-menu               switch-to-workspace-6
begin-resize                  move-to-side-e                panel-run-dialog              switch-to-workspace-7
close                         move-to-side-n                raise                         switch-to-workspace-8
cycle-group                   move-to-side-s                raise-or-lower                switch-to-workspace-9
cycle-group-backward          move-to-side-w                set-spew-mark                 switch-to-workspace-down
cycle-panels                  move-to-workspace-1           show-desktop                  switch-to-workspace-last
cycle-panels-backward         move-to-workspace-10          switch-applications           switch-to-workspace-left
cycle-windows                 move-to-workspace-11          switch-applications-backward  switch-to-workspace-right
cycle-windows-backward        move-to-workspace-12          switch-group                  switch-to-workspace-up
lower                         move-to-workspace-2           switch-group-backward         switch-windows
maximize                      move-to-workspace-3           switch-input-source           switch-windows-backward
maximize-horizontally         move-to-workspace-4           switch-input-source-backward  toggle-above
maximize-vertically           move-to-workspace-5           switch-panels                 toggle-fullscreen
minimize                      move-to-workspace-6           switch-panels-backward        toggle-maximized
move-to-center                move-to-workspace-7           switch-to-workspace-1         toggle-on-all-workspaces
move-to-corner-ne             move-to-workspace-8           switch-to-workspace-10        toggle-shaded
move-to-corner-nw             move-to-workspace-9           switch-to-workspace-11        unmaximize
move-to-corner-se             move-to-workspace-down        switch-to-workspace-12        
move-to-corner-sw             move-to-workspace-last        switch-to-workspace-2         
move-to-monitor-down          move-to-workspace-left        switch-to-workspace-3  

So,

how can I find the program that controls Ctrl+Alt+b (is there a registry or something in Linux that is similar to Emacs describe-key command)?

and how to disable it in the OS?

1
  • use [esc] [ctrl]-[B] instead
    – Jasen
    Aug 27, 2022 at 7:11

1 Answer 1

0

Not sure if there is a more general solution, but I found an answer from Lubuntu documentation. It seems that Ctrl+Alt-b isn't controlled by gsettings. Instead, it is set with:

lxqt-config-globalkeyshortcuts

and then in the dialog box, the first entry is Control+Alt+B for "Web browser". Unchecking it solved the problem.

Also present there are other shortcut keys such as Contorl+Alt+T for launching terminals.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .