How can I determine when Ubuntu was installed in my computer? There was a different question posted here.

  • 5
    What was wrong with the answers there? /var/log/installer, /boot, and dumpe2fs all look OK to me. – Mikel Feb 9 '11 at 10:41
  • @Mikel. The reason is that they show different dates. For instance, dumpe2fs and /var/log/installer show creation date as 05.11.2010 while /boot shows as 29.01.2011. That is why I wanted to find out precise method to get this information without any doubts. – Bakhtiyor Feb 9 '11 at 11:27
  • 3
    @Bakhtiyor Then most probably something happened to /boot. When dumpe2fs and /var/log/installer point to the same answer I won't keep any doubt. – phunehehe Feb 9 '11 at 11:49
  • All right guys. So, what do you suggest me to do with the question? Just delete it or what? – Bakhtiyor Feb 9 '11 at 11:52
  • @Bakhtiyor If you still think something is wrong and you need help with it please edit your question to include that information. Or if you question has already been answered on the other site you can close this one. – phunehehe Feb 9 '11 at 13:36

As I found here sudo grep ubiquity /var/log/installer/syslog | less should work for Ubuntu.

last works for Fedora.

  • 2
    Won't last suffer from the same issue with wtmp rotation? – belacqua Feb 10 '11 at 22:18
sudo dumpe2fs $(mount | grep 'on \/ ' | awk '{print $1}') | grep 'Filesystem created:'

Use this command for check when was the OS installed.

  • Thanks, this works! I would add "sudo" for completeness. – Aram Paronikyan Jun 8 '16 at 12:04

Use last. It helped me find the installation date on Fedora 14. The last line stating wtmp begins Tue Nov 9 22:35:12 2010 is the installation date.

  • wtmp begins Wed Feb 2 16:24:52 2011. This is what I get with last command in Ubuntu. Approximately my OS had been installed on November 2010. – Bakhtiyor Feb 9 '11 at 15:33
  • 1
    @Bakhtiyor Try grep ubiquity /var/log/installer/syslog | less. I found that here – Dharmit Feb 9 '11 at 15:41
  • 3
    I wouldn't rely on that. For example, FreeBSD rotates /var/log/wtmp by default, so when I run last on one of my FreeBSD boxes I get "wtmp begins Thu Feb 3 09:50:42 EST 2011". My Slackware box does the same thing, I installed the OS on it years ago but last reports that wtmp began last week. I don't have an Ubuntu box handy to check. – mazianni Feb 9 '11 at 15:43
  • @Dharmit. sudo grep ubiquity /var/log/installer/syslog | less worked for me. Could you please post it as an answer, so that I could select your answer as an accepted one. – Bakhtiyor Feb 9 '11 at 15:58
  • 1
    wtmp gets rotated. See /etc/logrotate.conf. – Mikel Feb 9 '11 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.