I run CentOS 6.4. I have SSD 300GB for system files and RAID10 8TB for storage + backup.

SSD system drive is partitioned as follows: fdisk -l /dev/sdb

Disk /dev/sdb: 300.1 GB, 300069052416 bytes
255 heads, 63 sectors/track, 36481 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc95ec64f

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          66      524288   83  Linux       (/boot)
/dev/sdb2              66        8421    67108864   83  Linux       (/)
/dev/sdb3            8421       12598    33554432   83  Linux       (/usr)
/dev/sdb4           12598       36482   191847576    5  Extended
/dev/sdb5           12598       16775    33554432   83  Linux       (/var)
/dev/sdb6           16775       18864    16777216   83  Linux       (/tmp)
/dev/sdb7           18864       35574   134217728   82  Linux swap / Solaris

RAID10 8TB (GPT) is partitioned as follows: parted /dev/sda print

Model: ASR7805 RAID 10 (scsi)
Disk /dev/sda: 7999GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system     Name     Flags
 1      8389kB  7399GB  7399GB                  primary             (LUKS)
 2      7399GB  7400GB  510MB   ext4            primary  boot       (/boot)
 3      7400GB  7468GB  68.7GB  ext4            /                   (/)
 4      7468GB  7503GB  34.4GB  ext4            /usr                (/usr)
 5      7503GB  7537GB  34.4GB  ext4            /var                (/var)
 6      7537GB  7554GB  17.2GB  ext3            /tmp                (/tmp)
 7      7554GB  7692GB  137GB   linux-swap(v1)  primary             (swap)
 8      7692GB  7992GB  300GB                   primary             (LUKS)

All I wanted is just to use 300GB of space on my /dev/sda (RAID10) for creating an identical image (backup) of my SSD in case of sudden failure. As you could see above, I have partitioned my RAID10 is just absolutely identical way as my current system SSD. Afterwards, I have created exact images of each partition that I have on my current SSD and extracted them to my RAID10 using dump/restore commands.

All is fully copied and set on my RAID10 just the same way as on my current SSD.

I have obviously edited my backed up fstab (on RAID10 /etc/fstab) using proper UUID for mounting on load.


Whatever I do I cannot properly load the system, as I restart and choose to load from RAID10. The system just doesn't boot (underscore is continually blinking)!?

I have tried to copy first 446 bite of boot sector (dd if=/tmp/mbrsdb.bak of=/dev/sda bs=446 count=1) from my SSD's MBR to my RAID10's MBR but it didn't work?

Now, as I'm all out of any other options, I would like to ask for your help?

  • A side note: using RAID arrays for backup is akin to storing your ammo near open fire... You'll never know when the house blows up. – Deer Hunter Apr 6 '13 at 19:31
  • Thanks, but at the same time you don't know when SSD fails? Having two resources failing at the same time - that is something outstanding, right? What are other options you could offer in my case? ;) – Ilia Rostovtsev Apr 6 '13 at 20:12
  • 1
    I have finally found out that I needed an extra partition on my GPT RAID10 drive with a flag bios_grub that GRUB would use upon setup. It's clearly explained here, for those who's interested in more details: sysresccd.org/Sysresccd-Partitioning-EN-The-new-GPT-disk-layout – Ilia Rostovtsev Apr 8 '13 at 16:24
  • Glad for you. Please feel free to make it into an answer and accept it. Useful information for posterity and all that... – Deer Hunter Apr 8 '13 at 20:11
  • Good idea, I will do it when I have time.. – Ilia Rostovtsev Apr 9 '13 at 17:53

You need to install GRUB properly onto the corresponding disk properly, not only copy of MBR. For GRUB2 it's grub-install

| improve this answer | |
  • I have tried it! I have to install it on GPT. Regular methods fail! I'm missing something!? I get an error The file /backup/boot/grub/stage1 not read correctly. – Ilia Rostovtsev Apr 6 '13 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.