1

After successfully installing Manjaro KDE without any problems, I proceeded to install i3 WM. Again, no problems when switching manually through SDDM, and I've also tweaked some of i3 configurations successfully. However, when I changed the autologin session — through KDE — to i3, now I receive a black screen with no functionality, and a mouse cursor, which features KDE's theme.

I suspected it was a problem with my .xinitrc, but I'm not sure. My .xinitrc comes from a previous Arch install from some time ago, which was working. I've also tried to use the get_session() function in the standard KDE .xinitrc, but it didn't work either. Here's what I've been using:

#!/bin/sh

xset r rate 300 40
xset s off
xset -dpms
imwheel

pacman -Sy &
xmodmap ~/.Xmodmap

exec i3

How do I even debug this? (I don't think this is a graphics driver problem, since both i3 and KDE were working fine a few steps before this happened...)

1 Answer 1

1

any chance imwheel is not available and your .xinitrc crashes at that point?

any output in ~/.xsession-errors?

(wanted to comment, but not privileged enough here to do that..)

9
  • I did install imwheel, but I'll check again in the .xsession-errors, thanks for the tip.
    – psygo
    Commented Aug 23, 2022 at 18:11
  • I haven't found any xsession-errors actually. Interestingly I've found out that going into the TTY and then starting X (startx) works perfectly fine. I've also tried to create an .xsession file with startx inside to see if it worked but it didn't. In my previous Arch install, I remembered that I was using startx inside my .bash_profile, but that didn't work either, unfortunately.
    – psygo
    Commented Aug 24, 2022 at 0:38
  • .xsessionrc with startx inside wouldn't do any good - X session load that file on startup (and startx would create a new X session, which would load this file again, ...)
    – LittleFox
    Commented Aug 24, 2022 at 14:37
  • what happens when you do not have any .xsessionrc in your home directory?
    – LittleFox
    Commented Aug 24, 2022 at 14:38
  • oh and at least I'm confused rn about .xinitrc vs .xsessionrc - also, you tried adding startx to a .xsession - double check file names
    – LittleFox
    Commented Aug 24, 2022 at 14:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .