0

Trying to stop the transmission daemon on debian 11 gives me:

start-stop-daemon --stop --chuid debian-transmission --exec /usr/bin/transmission-daemon -- --config-dir /var/lib/transmission-daemon/info

No /usr/bin/transmission-daemon found running; none killed.

But I'm pretty sure that's not the case:

root@91c79f82a860:/var/www/html# ps -ef | grep transmission
debian-+  1347     1  0 19:02 ?        00:00:00 /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info

System information:

root@91c79f82a860:/var/www/html# dpkg -s transmission-daemon | grep Version     
Version: 3.00-1
root@91c79f82a860:/var/www/html# lsb_release -a
No LSB modules are available.                 
Distributor ID: Debian                        
Description:    Debian GNU/Linux 11 (bullseye)

Also, I'm doing this inside a docker container, php:8.1.8-apache.

I extracted the start-stop-daemon CMD from the /etc/init.d/transmission-daemon.

1
  • Is this helpful? stackoverflow.com/questions/41148126 The comment / answer here say 2 things: (1) docker is not a VM, so daemons are not revisited when you just start one, and (2) the location of the needs to be correct inside/outside the docker.
    – alle_meije
    Aug 23, 2022 at 15:42

1 Answer 1

2
+50

If you ran start-stop-daemon under strace you'll see:

readlink("/proc/3130/exe", 0x7ffc68a5f890, 256) = -1 EACCES (Permission denied)

numbers can be different but the point is reading exe symlink results in EACCES.

Solution is to run docker container with --cap-add=SYS_PTRACE or --privileged option.

1
  • Thanks A LOT bro, it works!!! For future readers who might come across this question, add this to your docker-compose service definition: privileged: true Aug 24, 2022 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .