2

Following the instructions in https://wiki.winehq.org/Debian I get this error when trying to install wine in Debian 10 amd64 with apt-get install winehq-stable:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 7.0.0.0~buster-1)
E: Unable to correct problems, you have held broken packages.

So I try to install wine-stable and get the same output asking for wine-stable-i386 (= 7.0.0.0~buster-1)

When trying to install wine-stable-i386, we are led to an unsolvable situation:

https://pastebin.com/1XVd5HnC

I have checked that I allowed i386: dpkg --print-foreign-architectures prints i386

I had winehq already installed with no major problem, but when installing another package, wine and a bunch of lib* packages were removed. I don't know exactly which package caused this, but was probably one of these: qt5-default, openssl, libc6, zlib1g:amd64, build-essential or pkg-config. Looking at dpkg -l I see that often i386 packages have the flag rc, meaning that they were uninstalled leaving config files, so maybe the package in question uninstalled winehq and i386 lib* stuff.

I tried to install winehq-stable with aptitude install winehq-stable but doesn't solve the deal:

https://pastebin.com/bJ6YBMXU

My sources.list looks like this:

https://pastebin.com/3565Rxfu

Interestingly, I have tried to install libc6:i386 and debian just wants to remove everything else :_D

https://pastebin.com/gncTNK9R

It seems all problems come when trying to install any i386 thing.

I would prefer avoiding installing the whole system again, so any ideas about how to solve this are welcome!

The output of apt policy libc6 libc6:i386 is:

libc6:
  Installed: 2.28-10+deb10u1
  Candidate: 2.28-10+deb10u1
  Version table:
 *** 2.28-10+deb10u1 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
libc6:i386:
  Installed: (none)
  Candidate: 2.28-10
  Version table:
     2.28-10 500
        500 http://deb.debian.org/debian buster/main i386 Packages
        100 /var/lib/dpkg/status
0

1 Answer 1

1

Your repository indexes are inconsistent. Before installing multiarch packages, you need to ensure your system is fully up-to-date on all required architectures:

sudo apt update
sudo apt upgrade

The update step should ensure that your apt policy output shows the same candidate version for amd64 and i386 packages. The upgrade step is required because apt install installs the latest version of a package, and it can’t install an i386 package if the amd64 variant is already installed and isn’t the latest.

4
  • By inconsistent repository indexes you mean my sources.list is wrong? How should I change it? apt update and upgrade is something that I usually do and hasn't solved the problem, in fact I've done it right now and no new package was installed or updated.
    – user538228
    Commented Aug 21, 2022 at 14:39
  • Did it make any difference to the output of apt policy libc6 libc6:i386? Commented Aug 21, 2022 at 15:18
  • Nope :_D it's the same
    – user538228
    Commented Aug 21, 2022 at 18:57
  • That’s the part I’m having trouble making sense of — you should see a candidate version of 2.28-10+deb10u1 for both amd64 and i386. The discrepancy is the reason why apt can’t resolve the situation for you. Commented Aug 21, 2022 at 19:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .