0

I run a web server on Alpine Linux. Previously I used PHP7, and I wanted to upgrade to PHP8. What is the proper way to do this? I tried with apk del php7 and then apk add php8, but it looks like this does not work properly: a simple PHP test page with just <?php phpinfo(); ?> displays the right php version, but is missing the proper formatting. Under /var/log/apache2/error.log I don't see php related errors, though.

1 Answer 1

0

Correct procedure suggests to:

stop web service
purge old php version with extension
install new php version with extension
start web service

Correctness of this procedure depends on the way your system environment handles default configuration of installed packages. Focal point is: it is not enough to install php, also web service needs to be instructed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .