I am trying to change the 'Legacy Applications' setting in the gnome-tweaks but when I restart the shell (Alt+F2+r) it resets back to default.

  • I tried changing it via dconf and gsettings too but didn't work.
  • This solution doesn't help me either.

I'm using GNOME42 on Manjaro if that helps.

1 Answer 1


I came across your issue as I have had same experience on Manjaro Gnome.

I believe I figured out the issue! It looks like a conflict between the User Themes extension and the Legacy (GTK3) Theme Scheme Auto Switcher extension.

If you open the Extensions application and disable Legacy (GTK3) Theme Scheme Auto Switcher it seems to fix the issue. I have since logged out and restarted and my legacy theme has saved.

  • I can't reproduce it as I use arch (btw) now, but I asked my friend to reproduce this error and indeed it was the Legacy (GTK3) Theme Scheme Auto Switcher messing things up. Disabling that definitely works. Thanks
    – shasherazi
    Oct 4, 2022 at 16:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .