6

I am attempting a Debian 11 install on a SSD. The install .iso, debian-11.4.0-i386-DVD-1.iso, was written to a USB stick with the dd command. It creates a disk with 2 partitions, /dev/sdb1 and /dev/sdb2, which is readable by any linux computer.

The USB boots fine, goes through Graphical Install, language selection, keyboard selection. But then it hangs on the mounting and detecting installation media step, saying it can not be found, which is ridiculous as it is literally booting off the installation media.

An integrity test brings up "the file ./pool/main/b/breeze/breeze_5.20.5-4_i386.deb failed the MD5 checksum verification. Your installation media may have been corrupted"

8
  • 1
    Which USB boots fine, do you mean the USB stick? If cloned, it should work well. Did you check with a checksum, that the iso file was downloaded correctly? If the iso file is good. maybe the iso file is old-fashioned so that it assumes, that it boots from a DVD drive, and gets confused when booting from a USB stick. - The most recent debian iso I tested is debian-live-11.3.0-amd64-standard.iso and it boots without any problems when cloned to a USB stick.
    – sudodus
    Aug 16, 2022 at 17:23
  • I re-downloaded the .iso file and this time copied it to the USB stick with a cp command, which goes one step further but still fails at "load installer components from installation media". At this point maybe it's an actual debian bug?
    – Cheetaiean
    Aug 16, 2022 at 18:09
  • Edited to add results of an integrity test on my 2nd attempt at a USB live boot image.
    – Cheetaiean
    Aug 16, 2022 at 18:18
  • The Sha256 checksum is correct for the downloaded .iso, I do not know if that can be checked for the USB as well
    – Cheetaiean
    Aug 16, 2022 at 18:37
  • You can try with a live iso file from debian.org/CD/live; If still problems I suggest the following next steps: 1. Try with another USB stick, or wipe your current stick (overwrite it with binary zeros) and then clone from the live iso file; 2. Tell us as much as possible about your computer: brand name and model number of the computer itself and of the graphics chip/card and amount of RAM. Tell us also the history of the computer, what operating system(s) you have run in it, and how it has been working. Are there reasons to suspect, that there is some hardware problem?
    – sudodus
    Aug 16, 2022 at 19:06

2 Answers 2

4

I got this error initially while trying to install 11.5 using the debian-11.5.0-amd64-netinst.iso, as I used rufus to copy the iso. I tried again, copying the image using Win32DiskImager, as recommended in https://www.debian.org/CD/faq/#write-usb. That worked - I did not get this error message. Hope this helps.

4

I fixed this by using the "DD" copy mode in Rufus.

2
  • It's ironic when Rufus tends to do 'dd' better than dd itself
    – Cheetaiean
    May 9, 2023 at 16:56
  • Why!? This work for me but why?!
    – alireza
    Jan 2 at 7:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .