3

Sometimes my X behaves like it has «sticky keys» turned on. I have no idea how I activated it. Usually hitting the "sticky" key multiple times solves the problem, but it is nevertheless annoying.

I thought I had disabled sticky keys and other accessibility options with xkbset -a, but it still happens. Here are the relevant pieces from xkbset q:

Accessibility Features (AccessX) = Off
Sticky-Keys = Off
Two Keys Mask = On
Latch to Lock Mask = On
Slow-Keys = Off
Slow Keys Delay = 300
Bounce-Keys = Off
Debounce Delay = 300
AccessX Feedback = On
Use Fixed Pitch Bell = On

Any other places I should check?

I'm running Debian testing, xmonad window manager, and many gnome and kde applications. I suspect that it could be a gnome or kde feature.

2 Answers 2

2
+50

Mine did this too, sometimes. Everything would start doing unexpected things; mashing the meta keys a few times corrected the problem. It turns out I had a rubbish keyboard.

Are you sure you don't have an actual sticky key?

It doesn't have to look stuck. Sometimes it just seems to miss the key-up event.

5
  • This is an interesting theory. I wonder how I could check it next time this happens. Commented Jul 21, 2014 at 16:54
  • I've been thinking about this, and I can't come up with anything definitive. The problem is that, when it happens, you can't do anything to test it. Even mouse clicking is confused. It would need to be something that was running all the time, visible on screen, or writing to a log, just in case. Perhaps some key logging software (the kind people use to spy on others) might be useful?
    – ams
    Commented Jul 29, 2014 at 8:52
  • It's very disappointing this answer was awarded bounty. I get this problem sporadically on my laptop both with and without an external keyboard. (one of the many external keyboards I have tried is a Leopold FC660M, i.e. not a rubbish keyboard) Commented Jan 17, 2016 at 7:44
  • The answer was never accepted; the bounty was awarded by default.
    – ams
    Commented Jan 17, 2016 at 9:18
  • TBF, I've never reproduced the problem since I replaced that keyboard.
    – ams
    Commented Jan 17, 2016 at 9:24
2

Since Gnome 3.22, you can completely disable sticky keys, or adjust delay and speed, via Settings > Universal Access > Typing > Repeat Keys:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .