1

I just did an update in Arch Linux, and now the Videos app (Totem) is using the same icon for every control:

Totem screenshot

The controls still work; you just can't tell them apart without hovering over the control until the tooltip shows up. This worked fine before the upgrade.

I've reinstalled totem, gnome-icon-theme, gnome-icon-theme-extras, gnome-icon-theme-symbolic, and hicolor-icon-theme, but that made no difference.

Arch is currently on Gnome 3.6. I'm using x86_64.

How do I get the controls labelled with the right icons?

Update: When I start totem on the command line, I see the following lines added to ~/.cache/gdm/session.log:

Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x280000b (Videos)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

and the following lines on the terminal:

(totem:3232): Grilo-WARNING **: [registry] grl-registry.c:434: Could not open plugins' info directory '/usr/lib/grilo-0.2': Error opening directory '/usr/lib/grilo-0.2': No such file or directory
(totem:3232): Totem-WARNING **: Failed to load grilo plugins: All configured plugin paths are invalid. Failed to load plugins.

The grilo warnings I've seen before this problem started; I don't have it installed.

3
  • @don_crissti, yes, I'm using the default icon theme. I've tried changing icon themes with gnome-tweak-tool, but all that does is give me a different broken icon for all controls. – cjm Apr 5 '13 at 20:25
  • I tried updating the icon cache. I got no errors, but it didn't make any difference. Neither did rebooting. – cjm Apr 5 '13 at 21:20
  • @don_crissti, that did it! (Well, I only reinstalled librsvg and ran gdk-pixbuf-query-loaders --update-cache; I didn't use -Rdd). But the controls are back. Please post an answer so I can accept it. – cjm Apr 5 '13 at 21:49
2

This sort of behavior is usually caused by icon & pixbuf loaders problems.

Re-installing librsvg and running (as root):

gtk-update-icon-cache -f /usr/share/icons/gnome

gdk-pixbuf-query-loaders --update-cache

should, in most cases, fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.