0

I've done everything that I can find to set Chrome as my default browser. But some applications still run Firefox and I need to tell them directly to not do that.

Is there some hack to always force Chrome for every browser?

I have:

$ xdg-settings get default-web-browser
google-chrome.desktop

$ xdg-settings get default-url-scheme-handler http
xdg-settings: default-url-scheme-handler not implemented for xfce
alternatives --list

doesn't show any browser only:

google-chrome           auto    /usr/bin/google-chrome-stable

Settings default applications list Chrome as the default browser. But for an unknown reason both Firefox and Chrome say that they are the default browser inside settings. Firefox is even happy about this.

I've just installed OBS and I wanted to connect to YouTube but it ask me to log in to Google in Firefox. I don't want to use Firefox for any login. I only use it for debugging. I don't see any options for this in OBS.

The same happens in other applications like Liferea and Clawsmail they always open in Firefox unless I set it to open in Chrome. Those applications have a setting for that, but OBS doesn't.

1 Answer 1

0

I don't know much about this, but you can also check the output of these sorts of tests: to see if they say google-chrome.desktop:

xdg-settings get default-url-scheme-handler http
xdg-settings get default-url-scheme-handler https
xdg-settings get default-url-scheme-handler ftp

If they don't, set them with eg:

xdg-settings set default-url-scheme-handler https google-chrome.desktop
1
  • I was testing this, and forget to add to the question. This returns xdg-settings: default-url-scheme-handler not implemented for xfce.
    – jcubic
    Aug 15, 2022 at 17:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .