I am using fbpanel 7.0-4 on Debian 10.

I have applied patches from @Arkadiusz Drabczyk, to put fbpanel on one monitor, and to disable virtual desktop switching on mouse scroll:

fbpanel: only use one monitor


These patches work great, I just need one more small modification:

With the patches applied, mouse scroll no longer switches virtual desktops when cursor is on the panel. But it still acts as "minimize window" when mouse is scrolled directly on the application "dock" (or what is the right word) in the panel. Normally, I can minimize active window by left clicking on the application. That is useful. But also, when cursor is on the application, mouse scroll has same effect, also minimizing and maximizing the current window. This second action I would like to disable.

How can I disable this feature, or disable all mouse scroll actions entirely for fbpanel ?

I wand to disable mouse scroll only, not actions for mouse click.

  • @Arkadiusz Drabczyk - this is a followup question, to your previous answers. Would you kindly look at it? Thank you Aug 13, 2022 at 7:54

1 Answer 1


The taskbar documentation section is missing the option you need, but it is present in the source code as usemousewheel, so you don't need a patch.

plugin {
    type = taskbar
    config {
        usemousewheel = false

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .