0

tl;dr: Caps Lock acts as caps lock instead of switching keyboard layout as asked.


I believe I have correctly set the shortcut for switching layout:

enter image description here

but when I press caps lock, it still acts as caps lock, with the indicator even showing up in the system tray, next to the layout indicator (that does not change):

enter image description here

I can change the layout just fine using the icon in the system tray. It seems that _no other "Main shortcuts" works either, so this may not be related to caps locks, actually.

Update If I set CapsLock as the custom shortcut to "Switch to Next Keyboard Layout" in the "Shortcuts" panel of "System settings":

enter image description here

then Caps Lock actually changes the caps on top of changing the layout.

info
Linux 5.10.0-16-amd64 #1 SMP Debian 5.10.127-2 (2022-07-23) x86_64 GNU/Linux
Operating System: Debian GNU/Linux 11
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.0-16-amd64
OS Type: 64-bit

1 Answer 1

0

I have removed all the layouts, removed all the switching layout shortcuts, left "Caps Lock behavior" (in Hardware -> Input Devices -> Keyboard -> Advanced) by default, and rebooted.

Then, I re-added the layouts, and selected as a main shortcut "Caps lock", and it just work.

Not sure what did it, but apparently simply resetting the settings to default, rebooting, and re-creating the settings does it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .