0

GNU Typist is a well-known typing practice program for the terminal. I wanted to use it so I downloaded the .tar.gz from https://ftp.gnu.org/gnu/gtypist/?C=M;O=D. But when I untarred it and ran configure, it gives me the error

Error:  both library and header files for the ncursesw library are required to build this package.  See INSTALL file for further information. On Debian/Ubuntu you need to install libncursesw5-dev.

I already have ncurses and ncurses-dev installed (the branch is v3.15). I also tried installing ncurses5 and ncurses5-libs from branch v3.13 + ncurses-dev, but it shows me the same error. How do I fix this error?

1 Answer 1

1

Nevermind, I was being too pedantic with "everything must be managed by the package manager". In the configure file, the error was triggered by

if test -n "$HAVE_NCURSESW_H" -a -n "$HAVE_LIBNCURSESW";  then
   LIBS="-lncursesw $LIBS"
else
   echo -e "Error:  both library and header files for the ncursesw library\n"\
       "are required to build this package.  See INSTALL file for"\
       "further information. On Debian/Ubuntu you need to install libncursesw5-dev."
   exit 1;
fi

HAVE_NCURSESW_H is determined by these lines:

ac_fn_c_check_header_mongrel "$LINENO" "ncursesw/ncurses.h" "ac_cv_header_ncursesw_ncurses_h" "$ac_includes_default"
if test "x$ac_cv_header_ncursesw_ncurses_h" = xyes; then :
  HAVE_NCURSESW_H=1
fi

ac_fn_c_check_header_mongrel checks if a header exists. So I created a folder named ncursesw in /usr/include (temporarily) and copied ncurses.h to the folder. Ran configure and everything worked perfectly after that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .