-1

I'd like to run anybadge, but it fails with the following error. Why?

- apt-get update
- apt-get install --yes --no-install-recommends python3-pip
- pip3 install anybadge

Usage:

anybadge --label='mylabel' --value='myvalue' --file='my.svg' --color=yellow

Result:

Traceback (most recent call last):
  File "/usr/local/bin/anybadge", line 5, in <module>
    from anybadge.cli import main
  File "/usr/local/lib/python3.10/dist-packages/anybadge/__init__.py", line 2, in <module>
    from .badge import Badge
  File "/usr/local/lib/python3.10/dist-packages/anybadge/badge.py", line 13, in <module>
    from .templates import get_template
ImportError: cannot import name 'get_template' from 'anybadge.templates' (unknown location)
2
  • 2
    The issues is closed, so I'm voting to close this question as this was a very temporary problem.
    – muru
    Commented Aug 10, 2022 at 2:55
  • Please edit your post to include the version of anybadge that caused the problem.
    – AdminBee
    Commented Aug 29, 2022 at 8:01

1 Answer 1

0

Known issue, somehow an anybadge update is causing the problem: https://github.com/jongracecox/anybadge/issues/63

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .