4

When my system freezes randomly it starts to slow down heavily and in the end it does not react anymore. I can provoke it pretty consistently, if I start Firefox alone (with many tabs open) and start playing a YouTube video. Switching workspaces may contribute. On the other hand, it also happened while I was only running VSCode. The higher the hardware usage, the higher the chance that it freezes.

Sometimes I can get into a terminal with ctrl+alt+f1 just before that point. I would then run htop and look at the system utilization. Nothing special except for the M_SIZE (VIRT) which is always very high for both programs (higher than my ram capacity) but my ram usage is still not even at 60-70 %. I even increased my swap file, so it is less likely that ram is the cause of the issue.

Using Mint's protocol viewer, I found out that every time it freezes, the following messages are saved:

nouveau 0000:01:00.0: msvld: init failed, -19
nouveau 0000:01:00.0: msvld: unable to load firmware data
nouveau 0000:01:00.0: Direct firmware load for nouveau/nva8_fuc084d failed with error -2
nouveau 0000:01:00.0: Direct firmware load for nouveau/nva8_fuc084 failed with error -2

So, I tried to install the proprietary nvidia-340 driver that was recommended by Mint's driver manager. It failed with a dpkg error, and the same happened after trying it with apt. I found this thread about Nvidia ending their support for this driver. Further down in the post, you can see that the current kernel version is 5.15.0-43, but I also tried installing the driver (using the driver manager from Mint) on version 5.4.0-122.

After that, I tried to fix the nouveau driver. From this answer, I went to nouveau/VideoAcceleration documentation page and tried the commands under the firmware section. It froze again, so I reverted the changes.

What can I do to stop it from freezing? In case you think it is an overheating issue, then I wonder why it would not unfreeze later on because the load reduces, and the CPU cooler gets quieter.

System info and more: https://pastebin.com/HMTLfrD3

Edit: I verified that the freezing is not related to RAM/swap usage.

4
  • 1
    I have had similar issues with a laptop that had dual GPU support (Intel and Nvidia) while using Noveau in live USB Kubuntu sessions. Installing the Nvidia driver usually helped, but I think the 340 driver is for kernel 4.x, or of that era. For kernel 5.x, you should be looking at something like 430 IIRC. What do you get from a apt search nvidia (assuming you already ran sudo apt update)?
    – t0w0i7ne
    Aug 9, 2022 at 18:19
  • @t0w0i7ne The search returns around 6900 packages. I cannot even post this list on pastebin because it is too big. Aug 9, 2022 at 18:53
  • A/ Yes indeed installing nvidia proprietary drivers should solve your trouble. B/ Unfortunately the latest version of this driver corresponding to your device is the 340 which is no longer supported on latest kernels, latest x servers and so on. C/ I still manage to use it under linux-5.4 (without KMS) and xorg-server-1.20.8 (latest possible version since following ones require use of libglvnd for which 340 drivers are not compatible.) (Cont…)
    – MC68020
    Aug 10, 2022 at 10:12
  • (… Cont) Therefore, if you are ready to use linux-5.4, downgrade xorg-server + possibly DE + possibly rebuilding from source since these might no longer be available under your repository I can try to help you. But… you might well find easier to solve your troubles with nouveau.
    – MC68020
    Aug 10, 2022 at 10:13

2 Answers 2

5
+50

A/ Since you report an error related to firmware, the nvidia proprietary driver would surely not have that problem.
However, the 340 version is the latest being compatible with your device and because 340 does not support kernel modsetting, it is not longer compatible with linux > 5.4 kernels.
Moreover, because that driver version is not libglvnd compatible, it won't be compatible with xorg-server > 1.20.8, mesa > 20.0.8 and all related stuff not to say latest versions of many DEs.

Therefore, either you get a backup from these days running <=5.4 linux kernel and xorg-server <= 1.20.8, restore it and stop upgrading from there, either you are ready to downgrade many things… in a totally unsupported way. (since corresponding software might no longer be available in your repository).


B/ Either… you stick with nouveau, fighting the problem :

From what you report, I understand that msvld init is failing because the kernel cannot find the firmware... while watching some youtube video.

This is probably because :

  • AND you required video acceleration
  • AND your system cannot find the appropriate video codec.

I then suggest that you retry after disabling video acceleration in Firefox.

You might also well try if downloading the appropriate firmware (not redistributable for copyrights reasons) fixes the trouble. In order to proceed first check if your distribution gets the right package to install.
If not then read the chapter about video acceleration in the freedesktop wiki. and apply the fallback, mainly :

$ mkdir /tmp/nouveau
$ cd /tmp/nouveau
$ wget https://raw.github.com/envytools/firmware/master/extract_firmware.py
$ wget http://us.download.nvidia.com/XFree86/Linux-x86/325.15/NVIDIA-Linux-x86-325.15.run
$ sh NVIDIA-Linux-x86-325.15.run --extract-only
$ python2 extract_firmware.py  # this script is for python 2 only
# mkdir /lib/firmware/nouveau
# cp -d nv* vuc-* /lib/firmware/nouveau/

You might need to adapt taking into account your nouveau driver version.

5
  • Regarding A: This is helpful, but first I would like to go with B, unless nothing works, and I do not have any backups. Regarding B: As you can see in my question, I already was on the page and tried the commands you posted. I experienced weird graphic glitches, and it froze again later on. I tried disabling video acceleration, and it worked for some time. Then I increased the load by opening Visual Studio Code and the driver created trouble, once again. I managed to switch to the console prompt and stopped VSC. After that, everything worked again. Still, the problem remains unsolved. Aug 11, 2022 at 20:03
  • @ConfusedLearner : OK then : 1/ What DE do you run ? Mate ? Do you get a mean to disable compositing ? In case of positive answer, retry after disabling compositing. 2/ What are the results when, instead of watching a video via Firefox, you watch a video under your media player ? 3/ Don't generate load openning vsc. We can't determine precisely the problematic hardware resource. Install sysbench, open a terminal and while watching your video launch sysbench cpu --threads=1 run we should be able to isolate if cpu load is the problem.
    – MC68020
    Aug 11, 2022 at 21:33
  • 1: I am running Cinnamon and disabling compositing is only partly possible on Linux Mint. 2: It works well in almost all cases when I watch a full movie. 3: It is not very practical if I try this because the freezing happens randomly and the command runs for a short amount of time. However, I will try the option of downgrading the kernel and possibly other packages to install the proprietary driver, since it was not possible for me to fix nouveau, and it will not be fixed either. Aug 13, 2022 at 18:20
  • Could you update your answer to include some links at the beginning regarding the dependencies of the Nvidia driver? Maybe someone has a similar problem and does not know where to search to find a working environment. You wrote that kernel versions higher than 5.4 are not supported but as I wrote, installing nvidia 340 under the kernel version 5.4.0-122 did not work either. Aug 13, 2022 at 18:21
  • 1
    @ConfusedLearner : I am currently running troublefree linux-5.4.195 + xorg-server-1.20.8 + kde-plasma-5.23.5 with nvidia-drivers-340.108 I don't know Cinnamon and in particular it's dependencies on the libglvnd (which is the major blocking point of nvidia-340 regarding DEs and Xorg. So, if willing to follow that way then 1/ find the last version of Cinnamon not depending on libglvnd 2/ I do not know either your package manager. Would it be possible to let your package manager downgrade your system to these versions simply ? If not then do you get means to build those versions from source ?
    – MC68020
    Aug 13, 2022 at 21:36
2

It seems like you're having the same problem as I had before with my Macbook Pro Late 2008, it had a Nvidia Geforce 9600M and it would just freeze randomly on me with the Nouveau drivers, it seems like there is actually patches that you can apply to Nvidia 340.xxx drivers to get it to work with the newer kernels.

There are patcher's made already that can automatically build a Nvidia Driver package with patches for newer kernels. The one i used is https://www.if-not-true-then-false.com/2020/inttf-nvidia-patcher/

Just generate the nvidia driver with that patcher and install it, and it should work.

I'm actually using Nvidia Proprietary Drivers 340.108 on my Macbook Pro Late 2008 with Archlinux

I hope this helps

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .