3

I'm trying to create a custom Ubuntu 22.04 image using the following link. I'm not having luck on the Producing the CD image. I get all the way to the

sudo mkisofs -D -r -V "$IMAGE_NAME" -cache-inodes -J -l -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -o ../ubuntu-9.04.1-desktop-i386-custom.iso .

The reason this command doesn't work is because Ubuntu 22.04 doesn't have the isolinux/syslinux installed anymore. I've tried finding other ways to get this to write, but they either use isolinux.bin, or a .img that doesn't exist either. I've tried using the .img in boot/grub/i386-pc/eltorito.img, this causes the below error to occur

xorriso: FAILURE: Cannot find in ISO image: -boot_image ... bin_path='boot/grub/i386-pc/eltorito.img

I could use some help on getting this Ubuntu 22.04 custom image to write to a bootable image.

2
  • I believe isolinux is only required for BIOS boot. And you copied a line for a 32 bit version from 9.04? you need to use current info. I prefer to use standard ISO and run scripts to restore backup or customize install.
    – oldfred
    Aug 5, 2022 at 17:39
  • @oldfred if you go to the link it mentions 18.04, the command just so happens to have 9.04 in it. I’ve tried UEFI commands I’ve found, but none have worked. If you have a 22.04 current info on how to create a custom iso I’d love to read it. I also can’t use restore backup or customize install scripts in this particular setup, it’s gotta be run off a live CD which is why I need a custom iso. Edit- current info that doesn’t use a gui like cubic, something that the command line structure to create a bootable custom iso
    – reecezwoos
    Aug 5, 2022 at 18:53

2 Answers 2

2

You may ask xorriso-1.5.4 about a proposal how to replay the boot equipment:


xorriso -indev ubuntu-22.04-desktop-amd64.iso -report_el_torito as_mkisofs

You will find that it does not use any SYSLINUX/ISOLINUX software any more.

Older xorriso versions will not properly analyze the new layout. https://askubuntu.com/questions/1403546/ubuntu-22-04-build-iso-both-mbr-and-efi shows how to repack the 22.04 ISO with xorriso-1.5.2 or older.

The luxury variation needs xorriso-1.5.4 to work properly. It hides the details of getting and applying the proposal in a -boot_image command:


xorriso -indev ubuntu-22.04-desktop-amd64.iso -outdev new.iso \
        ... \
        ... xorriso manipulation commands like -map, -rm, -mv ... \
        ... \
        -boot_image any replay \
        -padding included -compliance no_emul_toc

See man xorriso for -map, -rm, -mv, -chmod ...

0

I think there is a problem with the ISO. All that should be required is, "dd if="[source iso]" of=[destination device]" and "status=progress" if you like. I've tried multiple times to create a live boot disk with ubuntu and xubuntu 22.04.1-desktop-amd64.iso ISO and while process succeeds, it will not boot from a BIOS setup for UEFI. I tried Fedora Ubuntu ISO USB and it booted up without a problem. Then I tried debian-live-11.5.0-amd64-xfce.iso and the USB stick booted fine. There is clearly something wrong with the Ubuntu ISO image. I used "dd" command, I used Multiwrite and I used xfburn. That reminds me, I also burned a DVD with xubuntu 22.04 ISO and it would not boot. I grabbed my Ubuntu 18 stick and it booted. I then grabbed my Ubuntu Studio 20.04 LTS DVD and it booted fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .