I have successfully installed and run Virtualbox previously on Windows and Mac hosts with linux Debian guests of crunchbang plus plus (and previously crunchbang) in the past, but the latest installation is proving problematic.

Everything runs fine until I install guest addition on the linux host (following all the normal instructions) - in previous installations it always worked fine, but now I am getting the following error messages on the screen. Bizarely the guest boots successfully one time into linux with guest additions, I then modify the size of the window and guest additions appears to work successfully, but when I reboot the next time everything is good until I log in then the following errors appear and I can get into a terminal window with ctrl-alt-f1, but in the openbox system nothing works...

Image below of the errors. Any suggestions very gratefully received.

enter image description here

details - host windows 10 fully patched to date... guest crunchbang plus plus - a minimal distro - , based on Debian 64bit v11 ... linux kernel version is 5.10.0-16-amd64

looking here it may be that I should use a different graphics controller, but I repeated the installation using the VBoxSVGA recommended and it still gave the same errors after the second boot up. ....

1 Answer 1


this is an answer.... but I would be interested in any comments on this...

after looking at this post I saw that the issue might be needing to run vbox in windows as an administrator... and this has made it work...

... but the problem now is that what I have found is that if I run vbox in windows not as an administrator then the linux installation gets trashed and I cannot login.. It is all good to the login, but successful username and password returns to a prompt for user name.

So I will have to have lots of cloned vboxes... ... unless someone knows how to recover these linux vboxes or (maybe off topic) a way to only allow an application in Windows to only run as an administrator.

Edit to ensure only runs as administrator in windows right click on the application and there is a checkbox in the advanced tab of properties -also the login problem may be an issue with shared folders and trying to specify a mount point - changing the shared folders to have blank mount point seems to resolve the login issue described above, but this is not tested and tentative.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .